
BIONUMERICS Tutorial:

Creating charts

1 Introduction

The Charts and statistics window in BIONUMERICS provides a uniform charting interface and
uses robust and logical concepts to guarantee that most if not all charting and plotting needs can
be answered. Not less than 16 major types of charts are available BIONUMERICS. The basis for
every chart is the data source, which contains different properties (see Figure 1). A property can
e.g. be a string (information field) or a character value.

In this tutorial you will learn how to create some of the most commonly used chart types in BION-
UMERICS and how to alter the appearance of a chart. For detailed information on the different
chart types and available fit models we refer to the manual.

Species Country Virulence Size

Entry1 V. aquaticus Belgium 3 47

Entry2 V. nemorosum France 9 23

Entry 3 V. palustris Denmark 7 34

... ... ... ...
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Figure 1: The data source and resulting charts.
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2 Preparing the database

The DemoBase Connected will be used in this tutorial and can be downloaded directly from the
BIONUMERICS Startup window or restored from the back-up file available on our website:

1. To download the database directly from the BIONUMERICS Startup window, click the
button, located in the toolbar in the BIONUMERICS Startup window. Select DemoBase
Connected from the list and select Database > Download ( ). Confirm the download
action.

2. To restore the database from the back-up file, first download the file DemoBase Connected.bnbk

from https://www.applied-maths.com/download/sample-data, under ’DemoBase Con-

nected’. In the BIONUMERICS Startup window, press the button, select Restore
database, browse for the downloaded file and select Create copy . Specify a name and
click <OK>.

In contrast to other browsers, some versions of Internet Explorer rename the
DemoBase Connected.bnbk database backup file into DemoBase Connected.zip. If this
happens, you should manually remove the .zip file extension and replace with .bnbk.
A warning will appear (”If you change a file name extension, the file might become un-
usable.”), but you can safely confirm this action. Keep in mind that Windows might not
display the .zip file extension if the option ”Hide extensions for known file types” is
checked in your Windows folder options.

A text file with additional chart information can be downloaded from the Applied Maths website
(https://www.applied-maths.com/download/sample-data, click on ”Chart data file”).

1. Download the file Chart data.zip from the Applied Maths website and extract the content.

2. Open the database DemoBase Connected.

3. Select File > Import... ( , Ctrl+I) in the Main window to call the Import dialog box.

4. Choose the option Import fields (text file) under the Entry information data item in the tree
and click <Import>.

5. Browse for the downloaded and unzipped Chart data.txt file and press <Next>.

6. In the Import rules dialog box highlight the row that corresponds to Key and press <Edit des-
tination>.

7. In the Edit data destination dialog box, highlight Key and press <OK>.

8. Select the fields Age, Date, Country and Serotype using the Ctrl-key and press <Edit desti-
nation> again.

9. In the Edit data destination dialog box, highlight Entry info field and press <OK>.

10. In the Create new dialog box that appears, leave the default names unaltered and press <OK>
and confirm the action.

The Import rules dialog box should now look like in Figure 2.

11. Press <Next> to move to the next page and press <Finish>.

12. Enter Chart data as name for the template and press <OK>.
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Figure 2: The import template mapping rules.

13. Make sure the created template is selected and press <Next> to move to the next page.

The last step of the wizard indicates that existing entries will be updated.

14. Press <Finish>.

The entry information is imported and displayed in the Database entries panel.

3 Bar graph

3.1 Example 1

1. Select a few entries in the Database entries panel of the Main window (not those labeled as
STANDARD in the Genus field) using the Ctrl-key. Alternatively, use the space bar to select a
highlighted entry or click the ballot box next to the entry.

2. Highlight the Comparisons panel in the Main window and select Edit > Create new object...
( ) to create a new comparison for the selected entries.

3. To clear the selection, press the F4-key.

4. In the Comparison window, select Statistics > Chart and statistics... (F7).

5. Select PhenoTest characters under Experiment character values in the dialog box that pops
up and press <OK>.

6. Choose Bar Graph in the next step and press <Next>.

7. Choose an entry from the list and press <Next>.
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8. In the final step choose Name as Label and press <Finish>.

A bar graph is created in the Chart area panel of the Charts and statistics window displaying the
character set of the selected entry. The rectangular bar of each character has a length proportional
to the character value. We will now add a second bar graph to compare the characters between
two entries.

Figure 3: Bar graph displaying the character sets of two entries.

9. In the Data source overview panel, select another entry under Entry values.

10. Select Plot > Add new plot from selected properties... ( ).

11. Click on Bar graph and press <Next>.

12. Press <Finish> again to obtain the bar graph.

The result looks as in Figure 3. More entries can be added to the chart in the same way.

13. Close the Charts and statistics window with File > Exit .

14. Close the Comparison window with File > Exit without saving the comparison.

3.2 Example 2

15. Select all entries in the Database entries panel of the Main window with Ctrl+A, and unselect
those labeled as STANDARD in the Genus field.

16. Highlight the Comparisons panel in the Main window and select Edit > Create new object...
( ) to create a new comparison for the selected entries.

17. To clear the selection, press the F4-key.

18. In the Comparison window, right-click in the header of the ”Genus” field in the Information fields
panel and select Create groups from database field from the menu. Alternatively select
Groups > Create groups from database field .

19. Press <OK> to create groups based on the ”Genus” names.

The three groups appear in the Groups panel along with their color, size and name (see Figure 4).
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Figure 4: The Groups panel.

20. In the Comparison window, select Statistics > Chart and statistics... (F7).

21. Select Comparison entries in the dialog box that pops up and press <OK>.

22. Choose Bar Graph in the next step and press <Next>.

23. Choose a character value from the list (e.g. FAME: Values: 18:0) and press <Next>.

24. In the final step choose Entry information fields: Genus as Label , Group names: Group
colors as Color , Entry information fields: Strain number as Second label , Group names
as Sort method and press <Finish> (see Figure 5).

Figure 5: Chart components.

A bar graph is created in the Chart area panel of the Charts and statistics window. The rectangular
bar of each database entry has a length proportional to the value of the selected FAME character.

Ideally, we would like to see the genus and species information as chart labels, rather than only
the genus name. Since only one chart label can be displayed at a time, we will create a derived
property , containing the first character of the genus name and the full species name.

25. In the Data source overview panel, select Genus (Label) under Current view .

26. Select Dataset > New derived property... ( ).

27. Select Abbreviate and press <Next> and <Finish>.
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A derived property Abbreviate (Genus) now branches off from the Genus (Label) property.

28. In the Data source overview panel, select the derived property Abbreviate (Genus) and while
holding down the Ctrl-key select Species. Select Dataset > New derived property... ( )
again.

29. Choose the option Merge two strings and press <Next>.

30. Select Abbreviate (Genus) as String 1, Species as String 2 and replace the comma with a
space in the Template text box so that the template looks as ”^1 ^2 ” (see Figure 6).

Figure 6: Merge two strings.

31. Press <Finish> to add the derived property to the Data source overview panel.

32. Right-click on the new derived property in the Data source overview panel (Merge two strings)
and choose Use as Chart Label .

33. Choose Plot > Edit active plot properties... ( ), specify Taxon as X axis label and press
<OK>.

The result looks as in Figure 7.

34. Close the Charts and statistics window with File > Exit .

35. Save the comparison by selecting File > Save ( , Ctrl+S).

36. Specify the name All and press <OK>.

37. Close the comparison with File > Exit .

The comparison All is now listed in the Comparisons panel of the Main window.

4 Profile chart

4.1 Example 1

1. In the Database entries panel of the Main window, double-click on an entry to open its Entry
window.

2. Select File > Charts and statistics... ( , F7).
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Figure 7: Bar graph.

3. In the Create chart dialog box, select RFLP1 Curve under Fingerprint experiments and press
<OK>.

4. Select Profile chart in the next step and press <Next>.

5. Highlight Value in the next step and press <Next> and <Finish>.

A profile chart of densitometric values from the RFLP1 profile for the selected entry appears in the
Chart area panel (Figure 8).

Figure 8: Profile chart from curve data.

We will now use the copy and paste functions to display another curve in the same Charts and
statistics window.

6. Bring the Main window back into focus without closing the Charts and statistics window.

7. Double-click on another entry in the Main window to open its Entry window.
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8. Select File > Charts and statistics... ( , F7).

9. In the Create chart dialog box, select RFLP1 Curve under Fingerprint experiments and press
<OK>.

10. Select Profile chart in the next step and press <Next>.

11. Highlight Value in the next step and press <Next> and <Finish>.

A profile chart of densitometric values from the RFLP1 profile for the selected entry appears in the
Chart area panel.

12. Select Plot > Copy active plot . Bring the first Charts and statistics window into focus and
select Plot > Paste plot .

The Charts and statistics window now contains two charts: the original one (cyan dots) and the
pasted one (red dots) (see Figure 9). Note that the original chart has a live data source whereas
the pasted chart does not, because it is just a copy which is not linked anymore to its parent Entry
window.

Figure 9: Two profile charts.

13. Close the Charts and statistics window with File > Exit and close the Entry window.

4.2 Example 2

14. Double-click on the comparison All in the Comparisons panel of the Main window to open the
saved comparison.

If the comparison All is not present in the DemoBase Connected, select all entries in
the Main window with Ctrl+A and unselect those labeled as STANDARD in the Genus
field. Highlight the Comparisons panel in the Main window and select Edit > Create
new object... ( ). In the Comparison window, right-click in the header of the ”Genus”
field in the Information fields panel and select Create groups from database field from
the menu and confirm the creation of the groups.

15. In the Comparison window, select Statistics > Chart and statistics... (F7).

16. Select Comparison entries in the dialog box that pops up and press <OK>.

c© 1998-2020 Applied Maths NV. All rights reserved. Not for Diagnostic Use.
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17. Select Profile chart in the next step and press <Next>.

18. In the next step choose PhenoTest: Values: c17 and press <Next>.

19. In the last step choose Entry information fields: Genus as Label and press <Finish>.

The value for character c17 is now displayed for all entries in the Chart area panel of the Charts
and statistics window. The label Genus identifies the entries on the chart.

A chart can be sorted according to a selected string or value property. As an example, we will sort
the chart according to the character it is based upon.

20. Right-click on c17 (Value) in the Data source overview panel under PhenoTest and select Use
as Chart Sort from the floating menu.

Now it becomes clear that there is a correlation between the intensity of the character c17 and the
genus. Alternatively, the genus name can also be used as a sort property:

21. Right-click on Genus (Label) in the Data source overview panel and select Use as Chart Sort
from the floating menu.

Ideally, we would like to see the genus and species information as chart labels, rather than only
the genus name. Since only one chart label can be displayed at a time, we will create a derived
property , containing the first character of the genus name and the full species name.

22. Highlight Genus in the Data source overview panel (probably indicated as Genus (Label)
(Sort)) and select Dataset > New derived property... ( ).

23. In the Create derived property wizard, select Abbreviate and press <Next>.

24. Leave the options on the second page to their defaults and press <Finish>.

A derived property Abbreviate (Genus) now branches off from the Genus property.

25. Select the derived property Abbreviate (Genus) and while holding down the Ctrl-key, select
Species.

26. Select Dataset > New derived property... ( ) to create a new derived property.

27. Select Merge two strings to concatenate the abbreviated genus name and the species name
into a new string and press <Next>.

28. In the next page, choose Abbreviate (Genus) as String 1 and Species as String 2. As
Template, replace the comma between ˆ1 and ˆ2 by a space so that the template looks as ”^1
^2 ” (see Figure 10).

29. Press <Finish> to create the new derived property.

30. Right-click on the new derived property Merge two strings and select Use as Chart label from
the floating menu.

This derived property can also be used to sort the chart:

31. Right-click on the derived property Merge two strings and select Use as Chart Sort from the
floating menu.

The profile chart can further be supplied with additional information fields. For example, a chart
point label can be added as follows:

32. Right-click on Strain number in the Data source overview panel and select Use as Chart Point
label from the floating menu.

c© 1998-2020 Applied Maths NV. All rights reserved. Not for Diagnostic Use.
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Figure 10: Merge two strings.

The strain numbers are now displayed as additional information on top of the chart points. The
current profile chart displays just one character for the selected set of entries. The legend shows
the symbol and color used for this chart (see Figure 11).

Figure 11: One profile chart.

By selecting additional numerical properties as chart values, a profile chart can display multiple
characters in the same graph:

33. Right-click on c19 in the Data source overview panel under PhenoTest and select Use as
Chart Value.

The chart now displays a profile for the two characters. The legend still lists one profile chart, but
containing multiple components. Alternatively, you can also display the second character profile in
a separate chart, which has the advantage that you can assign different colors or symbols to the
profiles.

34. First, remove character c19 from the current profile by right-clicking on c19 (Value) in the Data
source overview panel under PhenoTest and selecting Use as Chart Value from the floating
menu.
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35. Click on c19, hold down the Ctrl-key and click on the derived property Merge two strings.

36. Create a new chart with Plot > Add new plot from selected properties... ( ).

37. Select Profile chart and press <Next>.

38. Press <Finish> to create the profile chart.

The chart area is updated and the two characters are listed with a different color in the legend
panel.

39. Close the Charts and statistics window with File > Exit .

5 Contingency table

5.1 Example 1

1. In the Database entries panel of the Main window, make sure all entries are selected except the
”STANDARD” entries. With this selection, create a Charts and statistics window with Analysis
> Chart and statistics... ( , F7).

2. Select Currently selected entries and press <OK>.

3. Select Contingency table in the next step and press <Next>.

4. Choose Entry information fields: Country as Column and Entry information fields:
Serotype as Row and press <Finish> (see Figure 12).

Figure 12: Chart components.

By default, the contingency table displays the member counts per cell and the cells are colored
according to the member counts using a color scale blue-green-yellow-orange-red. In addition,
the order of the cells is determined by the appearance in the database (see Figure 13).
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Figure 13: Contingency table.

The currently selected entries are shown in the contingency table as yellow bars in the cells. The
width of the bar in a cell is proportional to the relative number of entries selected within the cell.

5. To clear the selection, press the F4-key.

6. Select the entries of a particular cell by clicking in the cell while holding down the Ctrl-key. To
select multiple cells at once, hold down the Shift-key while dragging the mouse over the cells
to select.

7. To change the appearance settings, select Plot > Edit active plot properties... ( ).

8. Select Alphabetical as Column sort and Row sort .

9. Choose Row percentages as Quantification and Gray scale as Cell background . Press
<OK> to apply the changes.

10. Close the Charts and statistics window with File > Exit .

5.2 Example 2

11. Repeat the steps in 5.1, but now choose 3D contingency chart as plot type and choose Entry
information fields: Country as First category and Entry information fields: Genus as
Second category .

The 3D contingency chart displays the frequency distribution in a 3D bar graph (see Figure 14).

12. Drag the mouse of the image to rotate the 3-D view in all directions.

13. Close the Charts and statistics window with File > Exit .
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Figure 14: 3D contingency chart.

6 Scatter chart

6.1 Example 1

1. Double-click on the comparison All in the Comparisons panel of the Main window to open the
comparison.

If the comparison All is not present in the DemoBase Connected, select all entries in
the Main window with Ctrl+A and unselect those labeled as STANDARD in the Genus
field. Highlight the Comparisons panel in the Main window and select Edit > Create
new object... ( ). In the Comparison window, right-click in the header of the ”Genus”
field in the Information fields panel and select Create groups from database field from
the menu.

2. In the Comparison window, select Statistics > Chart and statistics... (F7).

3. Select Comparison entries in the dialog box that pops up and press <OK>.

4. Select Scatter chart in the next step and press <Next>.

5. In the next step choose PhenoTest: Values: c17 as X axis and PhenoTest: Values: c19 as
Y axis and press <Next>.

6. In the last step, select Entry information fields: Strain number as First Label and press
<Finish>.

The two characters are now displayed in an X-Y coordinate system with c17 as X axis and c19 as
Y axis. Each dot in the scatter chart represents an entry plotted according to its respective values
for c17 and c19. It can be seen from this chart that the scatter for these two characters is not
random.

The Entry window can be revealed from the chart area by double-clicking on a dot. Additionally, it
is also possible to select entries in the chart area using Ctrl+click or by holding down the Shift-key
while dragging the mouse arrow over the dots to select.

c© 1998-2020 Applied Maths NV. All rights reserved. Not for Diagnostic Use.
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In dense areas with on the scatter chart, the Strain number information may become illegible,
and therefore using symbols or colors may be more informative.

7. First, remove the entry labels from the scatter chart by right-clicking on Strain number in the
Data source overview panel and selecting Use as Chart First Label .

8. Right-click on Group colors under Group names in the Data source overview panel and select
Use as Chart Color from the floating menu.

The chart area now looks as in Figure 15.

Figure 15: Scatter plot of two characters.

9. Close the Charts and statistics window with File > Exit .

6.2 Example 2

10. Repeat the steps in 6.1, but now choose 3D Scatter chart as plot type and choose PhenoTest:
Values: c17 , PhenoTest: Values: c18 and PhenoTest: Values: c19 as X, Y and Z axis
respectively.

11. In the last step of the wizard choose Group names: Group colors as Color label and press
<Finish>.

The 3D Scatter chart displays the data as a collection of points in a 3-D space, with the values of
three selected characters determining the position on the X, Y and Z axis (see Figure 16).

12. Drag the mouse of the image to rotate the 3-D view in all directions.

13. Close the Charts and statistics window with File > Exit .

7 Frequency bar graph

1. Double-click on the comparison All in the Comparisons panel of the Main window to open the
comparison.
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Figure 16: 3D Scatter chart.

If the comparison All is not present in the DemoBase Connected, select all entries in
the Main window with Ctrl+A and unselect those labeled as STANDARD in the Genus
field. Highlight the Comparisons panel in the Main window and select Edit > Create
new object... ( ). In the Comparison window, right-click in the header of the ”Genus”
field in the Information fields panel and select Create groups from database field from
the menu.

2. In the Comparison window, select Statistics > Chart and statistics... (F7).

3. Select Comparison entries in the dialog box that pops up and press <OK>.

4. Choose Frequency bar graph (colored) as chart type and press <Next>.

5. Choose Entry information fields: Country as Category and the Group names: Group col-
ors as Color label in the next step (see Figure 17) and press <Finish>.

A frequency bar graph is created in the Chart area panel of the Charts and statistics window (see
Figure 18).

6. Close the Charts and statistics window with File > Exit .

8 Pie chart histogram

1. In the Main window, make sure all entries are selected except the ”STANDARD” entries. With
this selection, create a Charts and statistics window with Analysis > Chart and statistics...
( , F7).

2. Select Currently selected entries and press <OK>.

3. Select Pie chart histogram table in the next step and press <Next>.

4. Choose Entry information fields: Genus as Column category and Entry information fields:
Country as Row category and press <Finish>.
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Figure 17: Chart components.

Figure 18: Frequency bar graph.

A pie chart histogram table displays the frequency distribution of the two selected categorical
properties, with one category represented as rows, the other as columns (cf. contingency table).
The frequency over the row and column category is indicated by the size of the pie charts.

5. Press the F4-key to clear the selection.

We will now add a third category (a color property):

6. In the Data source overview panel, select Serotype and select Dataset > New derived prop-
erty... ( ) to create a new derived property.

7. Choose Convert to color and press <Next> and <Finish>.
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8. Right-click on the new derived property Convert to color (Serotype) and select Use as Chart
Pie chart category from the floating menu.

The chart area now looks as in Figure 19.

Figure 19: Pie chart histogram.

9. Close the Charts and statistics window with File > Exit .

9 ANOVA chart

Before an ANOVA chart based on the Age information can be created, the property of this field
needs to be changed from String to Number :

1. In the Database entries panel of the Main window, right-click on the entry field header Age, and
select Field properties . . . from the pop-up menu that appears.

This action opens the Database field properties dialog box.

2. Change the Content type to “Number” and press <OK> to close the dialog.

3. In the Database entries panel of the Main window, make sure all entries are selected except the
”STANDARD” entries. With this selection, create a Charts and statistics window with Analysis
> Chart and statistics... ( , F7).

4. Select Currently selected entries and press <OK>.

5. Select ANOVA chart in the next step and press <Next>.

6. Choose Entry information fields: Age as Value and Entry information fields: Country as
Category (see Figure 20).

7. Press <Next> and <Finish>.
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Figure 20: Chart components.

The ANOVA chart is displayed in the Chart area panel of the Charts and statistics window and
summarizes the value property Age over the Country categories.

Optionally a color property can be added to the chart:

8. Highlight Genus in the Data source overview panel and select Dataset > New derived prop-
erty... ( ) to create a new derived property.

9. In the Create derived property wizard, select Convert to color and press <Next> and
<Finish>.

10. Right-click on the new derived property Convert to color (Genus) and select Use as Chart
color from the floating menu.

The chart area now looks as in Figure 21.

11. Close the Charts and statistics window with File > Exit .
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Figure 21: ANOVA chart.
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