
BIONUMERICS Tutorial:

Importing and processing AATI Fragment Ana-
lyzer curve files

1 Aim

The Fragment Analyzer is a capillary electrophoresis instrument from the company Advanced
Analytical Technologies (http://www.aati-us.com). The generated electropherograms can be
exported from the AATI PROSize R© data analysis software in csv or txt format and imported in
BIONUMERICS after installation of the Import fingerprint tools plugin.

In this tutorial the installation of the Import fingerprint tools plugin and the import and processing
of the AATI Fragment Analyzer curve files is covered.

2 Preparing the database

1. Create a new database (see tutorial ”Creating a new database”) or open an existing database.

Installing a plugin in a BIONUMERICS database is done from the Plugins dialog box (see Figure
1), which can be called from the Main window by selecting File > Install / remove plugins... ( ).

Once a plugin is installed, it is marked with a green V-sign. It can be removed again with the
<Deactivate> button.

If the selected plugin is documented, pressing <Show Manual> will open its manual in the Help
window.

Proceed as follows to install the Import fingerprint tools plugin, starting from the Plugins dialog
box:

2. Select the Utilities tab in the Plugins dialog box.

3. Select the Import fingerprint tools plugin in the list and press the <Activate> button.

4. Confirm the installation of the plugin.

5. Confirm the installation of the plugin and press <OK>.

Once the plugin is successfully installed, it is marked with a green V-sign in the Plugins dialog box
(see Figure 3).

6. Close the Plugins dialog box.

http://www.aati-us.com
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Figure 1: The Plugins dialog box.

Figure 2: Confirm installation of the Import fingerprint tools plugin.

Figure 3: Installed plugin.
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7. Close and reopen the database to activate the features of the Import fingerprint tools plugin.

Next a new fingerprint type experiment will be created that will hold the imported Fragment Ana-
lyzer data.

8. In the Main window, click on in the toolbar of the Experiment types panel and select Finger-
print type from the list (see Figure 4).

Figure 4: The Create a new experiment type dialog box.

9. Press <OK>, enter a name, for example “FragmentAnalyzer” and press <Next> (see Figure
5).

Figure 5: Specify a name.

10. In the next window, make sure that Two-dimensional TIFF files is selected and select the
dynamic range of your data (e.g. 12-bit). Press <Next>.

11. Press <Next> twice without altering the settings and press <Finish> to complete the creation
of the new fingerprint type.

The Experiment types panel now lists the fingerprint type FragmentAnalyzer.

3 Importing Fragment Analyzer data

1. Select File > Import... ( , Ctrl+I) to call the Import dialog box.

2. Select Import FragmentAnalyzer curves under Fingerprint type data (see Figure 7) and
press <Import> button to start with the import of the data.
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Figure 6: Fingerprint settings.

Figure 7: The Import dialog box.

The Import FragmentAnalyzer data wizard page appears (see Figure 8).

The FragmentAnalyzer import routine accepts FragmentAnalyzer csv files and txt files.

Pressing the <Browse> button allows you to select the csv or text file(s) that you want to import,
located on your computer, external drive or on a network location. Alternatively, files can be added
to the import list through drag and drop. The number of files and total size is displayed below
the list. With the <Delete> button all selected files are removed from the import list. All files are
deleted at once from the import list when pressing <Delete All>.

Using a template file sample information can be imported together with the curves. A template file
is a simple tab- or comma delimited file with two columns (no headers). The first column should
contain the column names present in the curve files and the second column should contain the
sample information (see Figure 9 for an example). In the last step of the wizard, the corresponding
BIONUMERICS information field can be selected.

3. Browse for the Fragment Analyzer file(s), optionally select a template file and press <Next>.

The Import rules dialog box is displayed (see Figure 10).

The content present in the first row in the csv/txt file corresponds to the first row in the grid. The
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Figure 8: The Import FragmentAnalyzer data wizard page.

Figure 9: A template file: column names (left) and sample information (right).

text Column ID is specified in the Source column.

Double-clicking on the row opens a new dialog, where the data destination can be selected (see
Figure 11). Typically, the information in the header row is linked to a new or existing Lane info
field or Entry info field .

Using the last row in the grid, the (parsed) file name of the selected file(s) can be stored in the
database. The text File is specified in the Source type column and the text Name is displayed in
the Source column.

4. Specify a destination for one or more selected rows by pressing the <Edit destination> button
or by double-clicking (see Figure 12 for an example).

5. Press <Preview> to check the defined rules (see Figure 13 for an example). Close the preview.

6. Press <Next> to go to the next step.

In the Import curves wizard page, following settings are available:

• The Curve start and Curve stop positions are by default set to 0% and 100% respectively.
Based on these settings, the complete curves are imported. By entering other start and stop
positions as percentages, specific parts of the fingerprint curves can be imported.

• Any peak with a height exceeding the OD range of the fingerprint experiments will appear
truncated. To avoid this, a Height factor can be applied. The Height factor is by default
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Figure 10: The Import rules dialog box.

Figure 11: Edit data destination.

set to “1.0” (= no height reduction). If the Height factor is set to e.g. “2”, the heights are
reduced by a factor two.

• Checking the option Invert curve X-axis will invert the curves (fragments at the top of the
curve will appear at the bottom and vice-versa) right before they are added to the database.

• With the option Do not link standard (ladder) lane checked, the ladder lane will not be
linked to an entry in the database.

7. Press <Next> to go to the next step.

The last step prompts for some final settings.

• If a row in the grid is linked to the Key field in the database, Key is automatically selected
as the entry link field. If entries are already present in the database with the same (parsed)
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Figure 12: Import template.

Figure 13: Preview.

key information, the import tool will link the data to these entries.

• If no row entry in the grid is linked to the Key field, but one or more rows are linked to an
entry information field in the database, these fields can be selected from the list. If entries
are already present in the database with this linked information, the import tool will link the
data to these entries. If the entries are not yet present in the database, the data will be linked
to new entries in the database (if the option Create x entries is checked in the last step of
the wizard).

• If no fields are selected from the list, no check for existing entries will be performed, and all
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Figure 14: The Import curves wizard page.

Figure 15: The Import links dialog box.

data will be linked to new entries in the database (if the option Create x entries is checked
in the last step of the wizard). New keys are automatically generated during import.

8. Press <Finish> to go to the final step.

Each import template has its own unique Name. Optionally, a descriptive text string can be entered
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Figure 16: The Import template information dialog box.

in the Description input field.

9. Specify a template name (e.g. Import FragmentAnalyzer files) and press <OK> to save all
template settings to the database.

Figure 17: Import template

When a template has been created and saved, the template Name is shown in the Import tem-
plates panel and is automatically selected (see Figure 17). The template Description is shown in
panel on the right.

The patterns can be linked to an existing fingerprint type experiment or to a new fingerprint type
experiment (<Create New>). When the fingerprints are linked to a new fingerprint type experi-
ment, the next dialog will prompt for the fingerprint type name (see Figure 18). The creation of the
new experiment needs to be confirmed (twice).

Figure 18: Create a new fingerprint type experiment.

10. Press <Next> to go to the next step.
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The last step prompts for some final settings (see Figure 19).

Figure 19: Database links.

• When Create x entries is checked, the import tool is allowed to create the new entries in
the database.

• Check the option Update x entries if you want the software to be able to update the infor-
mation for existing entries.

• If the option Select modified entries is checked, entries in the database that were modified
during the import routine will be selected after import.

11. Press <Finish> to start the import.

Entries are created/updated and are displayed in the Database entries panel of the Main window.
Linked sample information - if defined - is stored in the corresponding entry fields. When the option
Select modified entries was checked, the new/updated entries are marked by a checked ballot
box ( ).

The fingerprint files are displayed in the Fingerprint files panel and contain the corresponding
fingerprint patterns. The patterns are linked to the appointed fingerprint type experiment in the
database. The presence of a pattern for an entry/experiment combination is indicated with a
green colored dot in the Experiment presence panel.

4 Processing Fragment Analyzer data

1. In the Fingerprint files panel, double-click on one of the imported files to open the Fingerprint
window.

2. In the Fingerprint window, select File > Edit fingerprint data... ( ) to open the Fingerprint
processing window.

The OD range defined for the linked fingerprint type experiment is applied on every imported file.

3. To check (and optionally update) the OD range, select Edit > Edit settings... ( ) and select
the Raw data tab.
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Figure 20: The Main window after import of FragmentAnalyzer data.

The OD (or intensity) range can be update to any other value if needed: e.g. 12-bit (4096 values),
16-bit (65536 values), ....

4. Close the Fingerprint processing settings dialog box.

5. Make sure the Normalization tab is selected in the Fingerprint processing window.

6. Press to enter the normalized view.

For now, the ”normalized view” looks the same as the original view.

7. Select the reference lane and press to assign it as a reference lane or select References >
Use as reference lane.

8. Right-click on a band in the reference lane and choose Add external reference position.

9. Enter the size (in bp) of the reference band. Make sure to only add numerical values (so without
bp or kb).

10. Repeat this action for all other reference bands in the reference lane.

11. Press .

12. The program may prompt with the following question: ”The resolution of this gel differs con-
siderably from the normalized track resolution. Do you wish to update the normalized track
resolution?” If the question appears, answer <Yes>.

The reference system is now defined and saved with the fingerprint type experiment. When pro-
cessing new fingerprint files, run with the same reference system, the assignment of the reference
positions can be skipped: just assign the correct lane as reference lane (References > Use as
reference lane), execute Normalization > Auto assign... ( ) and inspect the assignments
made.

13. Select the Bands tab in the Fingerprint processing window.

If you want to use the curves to compare the patterns, no bands need to be assigned in the
sample lanes. If you want to compare the patterns using bands, you will need to assign bands in
the sample lanes in the last step. Usually, assigning bands in the sample lanes is done first with
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the software’s automatic band search, followed by manual corrections. Some trial and error might
be required to find the best settings for the automatic band search.

14. To automatically search for bands, press or select Bands > Auto search bands.

In the Band search dialog box, the currently selected lane is shown along the bottom.

15. To scroll through other lanes, press the < and > buttons on the left and right sides of the curve.

16. Press <Search on all lanes> to execute the band search with the specified settings.

Bands that are found are marked with a green horizontal line. Incorrect band assignments can be
edited manually. For more information we refer to the reference manual.

17. After you are satisfied with the band assignments, press to save the file.

18. Exit the Fingerprint processing window by selecting File > Exit .

When a reference system is added to a fingerprint type experiment, a calibration curve needs to
be created for this reference system that translates all band positions into metrics.

19. Open the fingerprint experiment type (FragmentAnalyzer in this workflow) by double-clicking
on the experiment type in the Experiment types panel.

20. In the Fingerprint type window, select Settings > Edit reference system or double-click on
R01.

The Fingerprint Reference system window appears with the message: ”Could not calculate cali-
bration curve. Not enough markers.”

21. When the molecular weights were entered as names for the reference positions, the molecu-
lar weights can be copied by selecting Metrics > Copy markers from reference system....
Confirm the action.

22. Designate a metric unit with Metrics > Assign units... enter e.g. kb and press <OK>.

23. Close the Fingerprint Reference system window, and close the Fingerprint type window.

More information about the follow-up analysis tools that can be applied on the patterns can be
found in the tutorials on the Applied Maths website or in the reference manual.
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