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BIONUMERICS Tutorial:

Importing sugar metabolization data from text
files

1 Aim

Sequential measurements that express an evolution of one parameter in function of another (e.g.
enzymatic activity, growth curves, etc.) are called trend type data and can be imported and ana-
lyzed in our BIONUMERICS software package.

In this tutorial you will learn how to import trend data in your BIONUMERICS database, how to fit
a curve through the measurement points, and how to deduce parameters from the curve function
to compare the samples.

2 Example data

The example text files from which we will import data in this tutorial contain trend data for 6 strains
and can be downloaded from the Applied Maths website: go to https://www.applied-maths.
com/download/sample-data and click on 'Trend data sample files’.

1. Open one of the files (e.g. BSU1072.txt) to examine the data that will be imported.

| BSU1072.txt - Notepad — O *
File Edit Format View Help
Time (h) Mannitol Inositol Sorbitol Rhamnose SL oA

1 @.2854183 @8.1266839 @.2485959 @.7791391 @2.6484611

2 8.4548433 8.1653758 8.5369149 @.91ad4e64 @.8849222

3 1.13@89688 8.1948297 8.5841197 1.2247@57 1.3633131
4 2.8998684 8.3243677 B.6332428 1.2852999 2.287833:

5 3.8617158 8.5317284 1.1851838 1.6816882 2.7616652

[ 3.7B96585 1.8598855 2.3468473 3.8788862 3.583886E

7 3.9813529 1.3811642 3.7243788 3.9128713 4.4838851

8 4.28@83855 1.8357635 5.8258697 5.8858825 5.558513¢%

9 4.1863565 1.9781981 5.6367882 6.9985779 5.9788732
1@ 4.3119595 2.2727818 5.6592983 8.6356179 6.4355347
11 4.2192171 2.3196973 6.9455743 9.4825726 6.7371534
12 4.28@9752 2.4495329 7.1968528 9.6945898 6.825114€
13 4.2816567 2.4874238 7.1416183 9.8128868 6.849968E
14 4.2284858 2.4711499 7.4388861 9.7613489 B.961537€ w
£ >

Figure 1: Text file: an example.

The text file contains a header, followed by the actual data in tabular format. In this table, the first
column contains the X-values (= time points, expressed in hours) and the other columns contain
the Y-values (= sugar concentration, expressed in mM). The first row describes the curve names
(= sugar names).


https://www.applied-maths.com/download/sample-data
https://www.applied-maths.com/download/sample-data

3 Creating a trend data type experiment

1. Create a new database (see tutorial "Creating a new database”) or open an existing database.

2. In the Main window, click on + in the toolbar of the Experiment types panel and select Trend
data type from the list (see Figure 2).

Create a new experiment type ? *

Select what kind of experiment type you want to create:

E% Fingerprint type ~
._ Character type

Y Sequence type

Py, Matrix type

M. Spectrumtype

F Seguence read set type
- v
. e b ok

Figure 2: New Trend data type.

3. Press <OK>, enter a name, for example Carbon sources and press <Finish> to complete
the creation of the new trend data type.

The Experiment types panel now lists the trend data type Carbon sources.

4. Open the Trend type window by double-clicking on Carbon sources in the Experiment types
panel.

The Trend type window is initially empty. Trend curves can be added either manually (Trend-
Curves > Add new trend curve...) or during import (see 4).

4 Importing trend data

1. Select File > Import... (&, Ctrl+l) to open the Import dialog box.

2. Choose the option Import trend data under the Trend data type data item in the tree and
press <Import> (see Figure 3).

3. Press <Browse> and browse for the downloaded text files in the Carbon sources folder.
The Input wizard page is updated (see Figure 4).

4. Press <Next>.

As this is the first time we import trend data into the database, we need to create a new import
template by specifying Import rules.

All columns detected in the selected text files are listed in the grid.

5. Select first row in the list and click <Edit destination> or simply double-click on the row. Se-

lect "X-axis” as the BIONUMERICS destination field under Trend curve value in the Edit data
destination dialog box and press <OK> (see Figure 5).

6. Click on "Mannitol” and whilst holding the Shift-key, click on "Lactose” to make a multiple selec-
tion of the 6 trend data curves.
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4. Importing trend data 3

Import ? *

Import data

Select the kind of data to import:

@ Entry information data

Import files containing a set of
Fingerprint type data measurements taken under a
Character type data series of conditions, such as

#% Sequence type data time, temperature or
"5 Matrix type data concentration.
1 Trend data type data

The input file should be a csv or
e tab-defimited text fil.
. Spectrum type data
* Sequence read sets data
@ Data exchange

Manage import templates

(o] | ome

Figure 3: Import tree.

Import trend data ? *
Input
Select the data to import.

Input: D C:lsers\Public\Carbon sources\BSU1072 bt E Browse... i

D CAUsers\Public\Carbon sources\BSU1262 b Delete

D CAUsers\Public\Carbon sources\BSU1288 b

" Delete Al

D C\Users\Public\Carbon sources\BSU1656. txt

D CAUsers\Public\Carbon sources\BSU1712 bt

D CAUsers\Public\Carbon sources\BSU1987 bt

6 file(s), less than 1 Mb

< Back Next = Cancel

Figure 4: The Input wizard page.

Edit data destination ? *

[ Entry info field

{@F Trend curve value
Bﬁ Carbon sources
@ =Create new=

[ Trend data info field

Cancel

Figure 5: Edit data destination.

© 1998-2020 Applied Maths NV. All rights reserved. Not for Diagnostic Use.



7. Press < Edit destination>, select "Carbon Sources” under Trend curve value as destination
and click <OK> (see Figure 6).

Edit data destination ? *

@ <None=
i @ Entry info field
{@F Trend curve value

------ L= Carbon sources:

I:l Trend data info field

Figure 6: Edit data destination.

BIONUMERICS tries to map the column names to existing trend data curves. When there is no
trend data curve present with the same name, you will be prompted to create the new trend data
curves.

8. Press <OK > and then < Yes> to confirm the creation of the curves.

9. Select the last row in the grid, i.e. the row containing the File name, click <Edit destination>
and link the field to the "Key” field. Press <OK>.

The grid is updated and should now look like in Figure 7.

Import template ? *

Import rules
Select import sources and the database destinations

Source type Source Destination type Destination
Time (h) Trend curve value : Carbon sources
File field Mannitol Trend curve value : Carbon sources Mannitol
File field Inositol Trend curve value : Carbon sources Inositol
File field Sorbitol Trend curve value : Carbon sources Sorbitol
File field Rhamnose Trend curve value : Carbon sources Rhamnose
File field Sucrose Trend curve value : Carbon sources Sucrose
File field Lactose Trend curve value : Carbon sources Lactose
File Name Entry information Key
Edit destination...
Preview...

|:| Show advanced options

< Back Next = Cancel

Figure 7: Import rules.

10. Press the <Preview> button to verify that all information will correctly be imported in the
database (see Figure 8).
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4. Importing trend data 5

Preview ? X
Nr.  Key X.. Mannitol Inositol Sorbitol Rhamnose Sucrose Lactose ™
1 BSU107Z 1 0.2054183 0.1265039 0.2485935 0.7751381 0.6434611 0.3753394
2 BSU1072 2  0.4548433 0.1653758 0.5369149 0.9104084 0.8849223 0.3866269
3 BSU1072 3 1.1309880 0.1948257 0.5841157 1.2247057 1.363313 0.4857357
4 BSU1072 4  2.0990684 0.3243577 0.6332420 1.2052999 22078335 0.8166276
5 BSU107Z 5 3.0617158 05317284 1.1851830 1.6816882 2.7616652 0.8558457
[ BSU1072 &  3.7896505 1.0598055 2.3468473 3.0780862 3.5830066 1.3821836
7 BSU1072 7  3.8813529 1.3011842 3.7243708 39128713 44338851 1.7858596
8 BSU1072 8  4.2003855 1.8357635 5.0250687 5.8850025 5.5505135 3.6667633
9 BSU1072 9 41863565 1.9781981 5.6367802 5.9905779 5.9768733 5.5060795
10 BSU1072 10 4.3119595 22727018 6.6592933 8.6356179 6.4355347 6.5774936

" BSUM07Z 11 42182171 23196973 6.9455743 5.4025726 B.7371534 7.1940099
12 BSUM072 12 42009752 24485325 7.1960528 56545090 68251140 74515348
13 BSUM07Z 13 42816567 24074238 71416103 5.8128860 6.54509686 77245221
14  BSUM072 14 42004858 24711499 7.4300061 9.7613489 6.9615370 7.6915789
15 BSUM07Z 15 42253411 24187545 7.3187057 10.0588528 6.7954706 7.8750075
16 BSU1072 16 43495493 24988415 7.3527352 5.9301089 T.0163252  7.9815472
17 BSUM07Z 17 43370325 24802711 7.3034246 5.8500371 6.9370452 7.7350459
18  BSUM072 18 42500807 24750445 73284813 10.1294913 69384898  7.8073869 v
>

Close

Figure 8: Preview of the parsed data.

11. Press <Next> to proceed to the Import links dialog box.

12. Check Key under Import links and press <Finish>.
The import template needs to be saved to be able to use it again later on.

13. Enter a Name for the import template (e.g. “Carbon sources template”) and optionally a De-
scription. Press <OK>.

14. Highlight the newly created template and click <Next>.

This next dialog will indicate that 6 new entries will be created during import (see Figure 9).

Import trend data ? X

Database links
Link the imperted records to database entries.
Double click on a cell to get an overview.

Overview
In "All levels’ create § entries and |:| update 0 entries

Select modified entries

<« Back Cancel

Figure 9: Create 6 new entries.

15. Press <Finish> to start the actual import. The progress of the import is shown while database
information is added to the BIONUMERICS database.

The entries are displayed in the Database entries panel and all entries are automatically selected
(see Figure 10).
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Sugar metabolization - BioMumerics

- a X
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Database: Sugar metabolization (_DefaultUser_) Entries: Loaded=6, View=6, Selected=6 1 experiments. CAUsers\Public\Documents\BioNumerics\Data 80\Sugar metabolization This is a time limted package valid until 2020-12-30

Figure 10: The Main window after import of the data.

The imported trend data is stored in the trend data type Carbon sources.

16. Double-click on the experiment Carbon sources in the Experiment types panel.

The 6 trend data curves are displayed in the Curves panel of the Trend type window (see Figure
11).

Trend data type 'Carbon sources' - O *
File Settings TrendCurves Parameters Window Help
1l
& & Iit €
R T - o T -
“# | Mannitol ~
“# | Inositol
| Sorbitol v
“# | Rhamnose < *
w " "
TIEAES Comparison settings
¥ | Lactose
~
Carbon sources settings
X axis unit:
Y axis unit:
........ v
=  Curves

Carbon sources -

Figure 11: The Trend type window.

5 Defining parameters

For visualization and comparison purposes, a default curve fit model needs to be specified.

1. In the Trend type window select Settings > Default trend curve model... to call the Trend
curve fit model dialog box (see Figure 12).

Bacterial growth and activity is usually analyzed using a Logistic growth fit.

2. Choose Logistic growth and check both Use offset and Use generalized formula.

3. Press <OK> to set the curve model.
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5. Defining parameters 7

Trend curve fit model ? *

Linear interpolation
Cubic splines
Lowess

Polynomial

Linear function
Legarithmic function
Exponential function
Power function
Hyperbolic function
Gaussian function
Gompertz
Michaelis-Menten
Cumnulative normal distribution

Use offset

Cancel

Figure 12: Set trend curve model.

Before any analysis can be done, parameters have to be defined. Parameters can be deduced
from the model function (Parameters > Model parameters...) or from the original data points
(Parameters > Statistics parameters...).

4. In the Trend type window select Parameters > Model parameters... to call the Trend curve
parameters dialog box.

5. Select Logistic growth and check Use model.

For taxonomy or typing purposes one might be interested in combining data from multiple param-
eters into one clustering or identification.

6. Enable the parameters Final value (Max) (i.e. the maximum value derived from the curve) and
Maximum slope (Smax) (i.e. the maximum growth rate) (see Figure 13) and press <EXit>.

Trend curve parameters ? *

Linear function
Legarithmic function
Exponential function
Power function
Hyperbolic function
Gaussian function
Gompertz
Michaelis-Menten

[ Use model

Active parameters
[ initial value (Min}
Final value (Max)
|:| Initial exponential growth rate (r)
|:| Initial doubling time (Tdoubl)

Cumulative normal distribution

|:| Time at maximum slope (TSmax)
[ Time at 5% growth (T05)

[ Time at 50% growth (T50)

[] Time at 95% growth (T35)

Meodel choices
[Juse offset

[ use generalized formula

Exit

Figure 13: Trend curve parameters.

The Parameters panel now contains the selected curve model parameters to be used for com-
parison (see Figure 15). Our imported samples can now be compared based on the selected
parameters rather than based on the original measurement points.

7. Select Parameters > Parameter properties... to call the Parameter properties dialog box (see
Figure 14).
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Parameter properties ? hed

Color range: .
Minimum value:

Maximum value: 10.000

R 1
i
| Add point || Delete point |

Figure 14: Parameter properties.

8. Change the color scale of the selected parameter using the red, green and blue sliders and
close the Parameter properties dialog box.

9. Change the color scale for the other parameter and close the dialog.

The color scales specified will be used when displaying the parameter values in the Comparison
window (see 6).

Trend data type 'Carbon sources'
File Setings TrendCurves Parameters Window Help
& & It 4
rvaneers
R T R N - - R S S S T S I -
~

¥ | Mannitel ~

Logist:Max Logistic growth Final value 0.0 10.000 B |

| Inostol Logist:Smax Logistic growth Waximum slope 00 10.000 |

¥ | Sorbtol

| Rnamnose v
¥ | Sucrose - -

+ |Lactose Comparison settings

. ~
Carbon sources settings

0 v

Figure 15: The Trend type window with two parameters defined.

10. Select Settings > General settings... (!it) to call the Curve settings dialog box (see Figure
16).

Trend data type settings ? *

Properties

X axis name: | Time

X axis unit:
¥ axis unit: m

Trend data visualisation

Indude zero in X axis
Indude zero in ¥ axis

Label curves with description

I oK I | Cancel | Apply

Figure 16: General settings.

11. Enter “Time” as X axis name, “Hours” as X axis unit, and “mM” as Y axis unit (see Figure
16). Press <OK>.

12. Close the Trend type window with File > Exit.
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6. Displaying trend data 9

6 Displaying trend data

1. Click on a colored dot in the Experiment presence panel of the Main window representing a
trend data type for a particular entry.

The curves for the selected entry are displayed in the experiment card (see Figure 17). Using the
pull-down list in the upper left corner of the card you can choose which curves to display.

| <All> v|®f"¢f}@@] ®

0

@

@

BSU1072

Figure 17: Experiment presence card.

2. Close the experiment card by clicking on the triangular button in the upper left corner.

Trend curves can also be displayed for multiple entries at a time in the same window. This is
achieved as follows:

3. Select a number of entries in the database for which trend curves are present using the Ctrl-
and Shift- keys. To select all entries at once select Ctrl+A.

Selected entries are marked by a checked ballot box (g).

4. Double-click on the experiment Carbon sources in the Experiment types panel to call the Trend
type window.

5. Select File > Create trend data window ([2]) to open the Trend data window.
The Curves panel displays all curves for all selected entries in a single plot (see Figure 18).

6. Close the Trend data window with File > EXxit.
7. Make sure a few entries are selected in the Main window.

8. Highlight the Comparisons panel in the Main window and select Edit > Create new object...
(+) to create a new comparison for the selected entries.

9. Click on the next to the experiment name Carbon sources in the Experiments panel to
display the selected curve model parameters in the Experiment data panel (see Figure 19).

10. Select TrendData > Show parameter values colors to display the values of the parameters
together with the color as defined in the Trend type window (see 5).

11. Select a parameter in the Experiment data panel, and select TrendData > Sort entries by
parameter value ( 1\ ).
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Trend data window (Carbon sources)
File Edit View Window Help

<Al |

Curves

s
E
0 5 10 15 20

Time {Hours)

D [ I~

BSU1072 Key: BSU1288

BSU1262 Curve: Mannitol

BSU1288

Description:
LogistMax: 6.464344 + 0.0347 mM
LogistSmax: 1.76395 + 0.009469 mM/MHours

Figure 18: Trend curves displayed for multiple entries at a time.

B Comparison - O X
File Edit Layout Groups Clustering Statistics Fingerprints Characters Sequence TrendData ReadSets Spectra Composite Window Help
o ; ;
BE & 3 &5 cowonsmure © € i
@,
[ premmnmnrann, [OY vendrogram Experiment data Information fields [ Similarites |
. “1m [+ 4 [t L] SO = 1
[ Teme O € ENE e |EE N W= B IINI3T e 1L O lit =@
@ 12, carvon sources ~ 1] carbon sources
o
< >
[cirece | g8 g d i
2@ g= 2@ a
) I z
fiame | S ®5 4% a8 3 TR ~
~ 150 688 093 1.55 BSU10T2
v 114 983 167 1.42 BSU1262
< > 133 441 0.80 202 BSU1288
242 400 132 0.02 BSU1656
foows | 1641048 275 bss
031 920 236 021
ﬁ ® i ﬁ g BSU1987
EACETI I ~
8
6 entries in comparison | 6 entries selected in database

Figure 19: The Comparison window.

The entries are sorted according to increasing value of the selected parameter.

12. A tab-delimited text file of the entries and trend data values contained in the comparison can be
exported with TrendData > Export character table.

13. Selecting TrendData > Create trend data window ([]) calls the Trend data window again
(see Figure 18).

14. A cluster analysis (Clustering > Calculate > Cluster analysis (similarity matrix)...) can

be performed either by comparing the original data points of the curves, or by comparing the
parameter values.
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6. Displaying trend data 11

15. To calculate correlation and regression on trend data, open the Trend analysis window with
TrendData > Perform trend analysis ([4).

© 1998-2020 Applied Maths NV. All rights reserved. Not for Diagnostic Use.
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