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BIONUMERICS Tutorial:

Importing and processing VNTR capillary elec-
trophoresis data

1 Preparing the database

1. Create a new database, install the MLVA plugin and create an MLVA scheme as described in
the tutorial: "Setup of an MLVA scheme”.

2 Importing curve files

Raw curve files from Applied Biosystems and Beckman (now AB SCIEX) sequencers can be im-
ported directly in BIONUMERICS. A batch of Applied Biosystems curve files can be downloaded
from the Applied Maths website (https://www.applied-maths.com/download/sample-data, click
on "VNTR sequencer trace files”). These example files will be used to illustrate the import steps.
Eight VNTR targets per sample were amplified: two pools were generated (MP1 and MP2), each
containing four PCR products, using four color dyes (6-FAM, VIC, NED, and PET).

1. Select File > Import... (&7, Ctrl+l) to call the Import dialog box, choose Import curves under
Fingerprint type data and press <Import>.

2. Browse to the downloaded and unzipped example data folder VNTR sequencer trace files
and select all Applied Biosystems curves files (extension .fsa). Press <Open>.

The files are displayed in the Input wizard page and the default suggested Fingerprint file name
is the folder name.

3. Change the name to Batch1 and press <Next> (see Figure 1).

The way the information should be imported in the database should be specified with an import
template. In the example data set, the dye name can be parsed from the file information and the
sample and pool information can be parsed from the file names.

4. Select the predefined template Example import with pools and press the <Preview> button
to check the rules applied on the selected files.

In the preview we see that the part of the file name appearing before the underscore is linked to
the Key field. The curve dyes are also correctly linked to the Fingerprint dye type. In a next step,
we will modify the rule for the Fingerprint pool: we will link the part of the file name appearing
after the underscore and before the hyphen (”-”) to the Pool field.

5. Close the preview.


https://www.applied-maths.com/download/sample-data

Import fingerprint curves ? *

Input
Select the data to import.
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[ 7] casersi10...\N2006-0003_MP2-140708.fsa
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Figure 1: Selected curve files and fingerprint file name.

Preview ? hed
Nr.  Fingerprint pool Fingerprint dye Key G
1 MP1-140708 5-FAM N2006-0003
2 MP1-140708 Vic N2006-0003
3 MP1-140708 NED: N2006-0003
4 MP1-140708 PET N2006-0003
5 MP1-140708 LIZ N2006-0003
[ MP2-140708 G-FAM N2006-0003
7 MP2-140708 viC N2006-0003
8 MP2-140708 NED: N2006-0003
9 MP2-140708 PET N2006-0003
10 MP2-1407028 LIZ N2008-0003
" MP1-140708 G-FAM N2006-0004
12 MP1-140708 Vic N2006-0004
13 MP1-140708 NED: N2006-0004
14 MP1-140708 PET N2006-0004
15 MP1-140708 LIZ N2006-0004
16 MP2-140703 G-FAM N2006-0004
17 MP2-140708 viC N2006-0004
18 MP2-140703 NED: N2006-0004
19 MP2-140708 PET N2006-0004 v

Figure 2: Preview of predefined template.

6. Make sure the predefined template Example import with pools is still selected and press the
< Edit> button to edit the rules.

7. Check the option Show advanced options, make sure the second row is selected in the grid
panel and press the <Edit parsing> button.

8. In the Data parsing dialog box, update the data parsing string: “*_[DATA]-*". The asterisk will
serve as wildcard.

9. Press the <Preview> button and press < OK> when the parsing is correct (see Figure 3).
The Import rules dialog box is updated.

10. Press the <Preview> button to check the outcome of all defined import rules (see Figure 4).

11. Close the preview and press <Next> to go to the next step.
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Edit data parsing ? *

@ Parse component: find the component [DATAT, use ™ as wildcard

O Regular expression: match the expression and use the subexpression

Data parsing string: * [DATAL* v|
Data decoration: | [DATA] v|
Preview

Data: | N2005-0003_MP1-140708 | Preview...
Output: | 1P |

Figure 3: Parsing string.

Preview ? X
Nr.  Fingerprint pool Fingerprint dye Key =
1 MP1 G-FAM N2008-0003
2 MP1 Vic N2008-0003
3 MP1 NED: N2008-0003
4 MP1 PET N200§-0003
5 MP1 LIZ N2008-0003
[ MP2 G-FAM N2008-0003
7 MP2 viC N2008-0003
8 MP2 NED: N2008-0003
9 MP2 PET N2008-0003
10 MP2 LIZ N2008-0003
" MP1 G-FAM N2008-0004
12 MP1 Vic N2008-0004
13 MP1 NED: N2008-0004
14 MP1 PET N2008-0004
15 MP1 LIZ N2008-0004
16  MP2 G-FAM N2008-0004
17 MP2 viC N2008-0004
18  MP2 NED NZ008-0004
19 MP2 PET N2005-0004 2

Figure 4: Preview of the import rules.

In the example data set, the LIZ channel contains the size standard (GeneScan 500 LIZ).
12. Make sure LIZ is selected as Reference dye and press <Next> and <Finish>.
The predefine import template is now updated.

13. Make sure <Create new> is selected as fingerprint type experiment, make sure the Example
import with pools template is selected and press <Next>.

14. Specify a name for the new base fingerprint type experiment (e.g. MLVA) and press <OK> and
confirm.

15. Confirm the proposed OD range.

A fingerprint type needs to be present in the database for each pool and dye combination. The
names of these fingerprint types are composed of the base fingerprint type name, followed by the
pool name, and the name of the dye. If one or more of these fingerprint types are not present in
the database, a new dialog box pops up, listing the missing fingerprint types (see Figure 6).

16. Confirm the creation of the missing fingerprint type experiments.
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Provide a name for the new fingerprint type:

|
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Figure 5: New base fingerprint type experiment.

Mew experiment types ? x
These 10 new experiment types will be created:

MLVAMP16-FAM ~

MLVAMPILEZ

MLVAMPANED

MLVAMP1PET

MLVAMPIVIC

MLVAMP2E-FAM A

Do you want to continue?

Yes ] No

Figure 6: Missing fingerprint experiments.

17. Press <Next> to confirm the creation of new entries in the database.

18. Make sure Open curve preprocessing window is checked in the last step and press
<Finish>.

For each dye checked in the Dyes panel of the Import data dialog box, a new fingerprint file is
created, composed of the file name specified and the name of the dye (e.g. Batch1_LIZ). These
files are displayed in the Fingerprint files panel. The reference file is shown in the Link column.
Double-clicking on a fingerprint file opens the Fingerprint window. If lane information was imported
with the individual lanes, this information is displayed in the Fingerprint information panel.

The imported fingerprint lanes are linked to new entries in the database. The lanes are linked
to the corresponding fingerprint "dye” type. The names of these fingerprint types are composed
of the base fingerprint type name, followed by the pool name, and the name of the dye. The
fingerprint type experiments are displayed in the Experiment types panel.

Entries for which fingerprint data was imported are selected in the database.

After data import, the Main window looks as in Figure 7.

3 Processing curve files

When the option Open curve preprocessing window was checked in the last step of the import
routine, the Fingerprint curve processing window opens when pressing the <Finish> button. All
channels from the run are automatically loaded and displayed in the Fingerprint curve processing
window.

The Fingerprint curve processing window can also be called from the Main window
by highlighting one of the channels in the Fingerprint files panel and selecting Open
fingerprint data... (i5). Alternatively, you can first open the Fingerprint window with
Edit > Open highlighted object... (%, Enter) and then select File > Edit fingerprint
data... ().

1. Click on the © icon left of the data channels in the Channels panel.
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MLVA database - BioNumerics - O X
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Figure 7: The Main window after import of the data.

The data channels are now hidden from the view and its icons are displayed as
2. Use the zoom sliders on the left and on top to optimize the display of the fingerprint curves.

Since the raw chromatogram files have not undergone any preprocessing, normalization will have
to be performed. This requires a reference system to be defined, based upon the marker peaks
available in the reference dye.

3. Make sure the reference dye is the only dye visible in the upper panel.

4. Select Bands > Search reference bands... (dt, Ctrl+F) to call the Search reference bands
dialog box.

5. Leave the default settings unaltered and press <OK>.

The bands that fall within the specified criteria are marked with a solid line at the band’s position
(see Figure 8).

6. To have a reference system automatically created based on a lane containing commercial size
marker, first highlight a suitable lane and then select References > Define size standard....

This will display the Size standard dialog box, from which a size marker can be selected (see
Figure 9).

In the example curve files, the GeneScan 500 LIZ size standard is used as reference, containing
16 bands with known molecular weight.

7. Select GeneScan 500 LIZ from the list, select Pattern match and press <OK> twice.

8. Save the data to the database with File > Save ([2, Ctrl+S). Confirm the action.

BIONUMERICS will automatically create the reference system and calibration curve for each of
the fingerprint types. Since this allows the calculation of metrics information, a metrics scale now
becomes available in the upper part of the Fingerprints panel.

Normalization is achieved by assigning bands in the reference channel to external reference posi-
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Fingerprint curve processing
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Figure 8: The Fingerprint curve processing window only displaying the reference
dye.
Size standard *
Pre-defined standard: Standard fragment list:
GeneScan™ 120 LIZ& 35,50,75,100,139,150,160,200,250,300,340,350,400,450,49
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Figure 9: Select marker from the list.
tions.

9. To normalize a complete run at once, select Normalization > Auto assign reference posi-
tions (all lanes)... (&%, Ctrl+A), leave all settings unaltered and press <OK>.

10. When the assignment of the marker bands to reference positions is made, the data can be
shown in normalized mode with Normalization > Show normalized view (=, Shift+N).

11. Click on the

12. Click on the @ icon left of the LIZ reference channel.

icon left of the data channels in the Channels panel.
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Fingerprint curve processing - m] b4
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Figure 10: Normalized view - reference dye.

The data channels are now shown and the reference channel is hidden from the view.

13. Select Bands > Search data bands... (&*, Ctrl+Shift+F) to call the Search data bands dialog
box.

14. Check Remove doublets, Remove shadow bands, Filter by fragment length and specify a
minimum length of 50. Press <OK>.

15. Save the changes and close the Fingerprint curve processing window. Confirm the new de-
faults.

The reference system and calibration curve are automatically created for each of the fingerprint
types. We can check this from the Main window:

16. Double-click on the base fingerprint type in the Experiments panel to open the Fingerprint type
window.

17. In the Fingerprint type window, call Settings > Edit reference system, or double-click in the
RO1 panel to call the Fingerprint Reference system window.

A calibration curve for the reference system R01 of the base fingerprint type is displayed.

18. Close the Fingerprint Reference system window and the Fingerprint type window.
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Figure 11: Normalized view - data dyes.
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Figure 12: The Fingerprint Reference system window, with a calibration curve dis-
played.

© 1998-2020 Applied Maths NV. All rights reserved. Not for Diagnostic Use.



	Preparing the database
	Importing curve files
	Processing curve files

