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e Crypto++ library version 5.5.2, http://www.cryptopp.com/

e OpenSSL library, https://www.openssl.org/

e libSVM library for Support Vector Machines, http://www.csie.ntu.edu.tw/~cjlin/libsvm/
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e BioPython Python library version 1.64, http://www.biopython.org/
e PIL Python library version 1.1.7, http://www.pythonware . com/products/pil/

e Chromium Embedded Framework, https://bitbucket.org/chromiumembedded/cef/wiki/
Home
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e Unicycler version 0.4.8, https://github.com/rrwick/Unicycler/releases *

e Velvet for Windows, source code can be downloaded from https://www.applied-maths.
com/download/open-source

e Ray for Windows, source code can be downloaded from https://www.applied-maths.com/
download/open-source

e Bowtie2 version 2.2.5 (http://bowtie-bio.sourceforge.net/bowtie2/index.shtml)”
e SNAP version 1.0.18, http://snap.cs.berkeley.edu/
e RAXML version 8.2.11, https://github.com/stamatak/standard-RAxML/releases

e FastTree version 2.1.10, http://www.microbesonline.org/fasttree/
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Chapter 1

Starting and setting up BIONUMERICS

1.1 Introduction

This guide is designed as a tutorial for the MLVA plugin of BIONUMERICS. MLVA stands for Multi-
Locus VNTR Analysis and the MLVA plugin allows the determination of VNTR copy numbers based
on fingerprints, generated on capillary electrophoresis systems. See 2.1 for more information on
MLVA principles and used terminology. One or more MLVA schemas can be set up per database
and the plugin makes it possible to manage and assign MLVA types based on VNTR profiles.

The MLVA plugin is supported in the BIONUMERICS-GEL, BIONUMERICS-MALDI and BIONUMERICS-
SUITE configurations.

1.2 Startup program

Make sure the latest version of BIONUMERICS is installed (https://www.applied-maths.com/
download/software). The installation manual can be downloaded from https://www.applied-maths.
com/download/manuals.

When BIONUMERICS is launched from the Windows start panel or when the BIONUMERICS

shortcut () on your computer’s desktop is double-clicked, the Startup program is run. This

gmm

program shows the BIONUMERICS Startup window (see Figure 1.1).
A new BIONUMERICS database is created from the Startup program by pressing the button.

An existing database is opened in BIONUMERICS with B or by simply double-clicking on a
database name in the list.

1.3 Creating a new database

3.1 Press the button in the BIONUMERICS BIONUMERICS Startup window to enter the New
database wizard.

3.2 Enter a name for the database, and press <Next>.


https://www.applied-maths.com/download/software
https://www.applied-maths.com/download/software
https://www.applied-maths.com/download/manuals
https://www.applied-maths.com/download/manuals
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4
BIONUMERICS

VERSION 8.0

Database Last accessed Comment

DemoBase Connected 2015-03-02 16:12

) — Appiied Maths

Figure 1.1: The BIONUMERICS Startup window.

A new dialog box pops up, prompting for the type of database (see Figure 1.2).

3.3 Leave the default option selected and press < Next>.

MNew database ? *

New database
Create a new BioNumerics database

ics uses a relati datab as data storage.

Create new

Create a database on this computer.

Use existing

Use an existing database created on this computer or another
computer in your network.

« Back E Next> | Cancel

Figure 1.2: The New database wizard page.

A new dialog box pops up, prompting for the database engine (see Figure 1.3).

3.4 Leave the default option selected and press <Finish> to complete the setup of the new
database.

All rights reserved. Not for Diagnostic Use.



1.4. Installing the MLVA plugin 7

MNew database ? *

Engine
Select which engine to use for storing data.

Use default {SQLite)
RECOMMENDED: SQLie is an optimal sclution for file-based databazes.

O MS SQL server express® based

Ascalable, fast solution with storage up to 10Gb.

Use MS Access® based

Limited storage and not compatible with 64-bit applications.

< Back Cancel

Figure 1.3: The Database engine wizard page.

1.4 Installing the MLVA plugin

The Plugins dialog box can be called from the Main window by selecting File > Install / remove
plugins... (=) (see Figure 1.4).

Plugins ? *

Applications  Utiities Custom Database Functionality

Activate functionality for specific applications.

This plugin tool provides extra functionality for
BandScoring the import of antibiotic susceptibilty data based
E. coli functional genotyping on MIC or disk diffusion method. The tocls will
Listeria functional genotyping also convert the range into 5-+R categories.

MTBC functienal genotyping
lla functional genotyping
5. aureus functional genotyping
HIV Resistance
MIRU-WVNTR
MLST online
Qlaxcel
ROP
RiboPrinter
SNP calling
Spa typing
Polymorphic WNTR typing
MLVA
WGS tools

|:| Show only activated

Show Manual

e

Figure 1.4: The Plugins dialog box.

When a particular plugin is selected from the list of plugins, a short description appears in the right
panel.

A selected plugin can be installed with the <Activate> button. The software will ask for confir-
mation before installation. Some plugins are only supported in specific BIONUMERICS configu-
rations. If the plugin is not supported by your BIONUMERICS configuration, it cannot be installed
and an error message will be generated.

Once a plugin is installed, it is marked with a green V-sign. It can be removed again with the
< Deactivate> button.

If the selected plugin is documented, pressing <Show Manual> will open its manual in the Help

All rights reserved. Not for Diagnostic Use.



8 1. Starting and setting up BIONUMERICS

window.

4.1 Select the MLVA plugin from the list in the Applications tab and press the <Activate> button.
The program will ask to confirm the installation of the plugin.

4.2 Press < Yes> to confirm the installation of the MLVA plugin.
A message appears, stating that the MLVA database components need to be updated.

4.3 Press < Yes> to continue.

Updating the MLVA database components will involve creating additional tables and
columns in the database to hold MLVA-specific information. Therefore, the current user
requires CREATE TABLE and ALTER TABLE privileges on the relational database. This
will always be the case for a MS Access, MS SQL Server Express or SQLite database
created by BIONUMERICS. For a shared database on a central database server, please
check with your database administrator before proceeding.

When the database update is finished, the MLVA plugin is completely installed.

4.4 Press <Exit> to close the Plugins dialog box and to continue to the Main window.

4.5 Close and reopen the database to activate the features of the MLVA plugin.

The MLVA plugin installs several menu items and buttons in the Main window (see Figure 1.5).
In order to visualize the buttons, it might be necessary to select Window > Restore default
configuration from the menu or to restart the software.

MLVA test - BioNumerics

File Edit Database Analysis Scripts QUIRYSE Window Help

S8 o O b
nmn :q':"] D]l] @']l] @l Assign VNTRs...

f0  Assignment report ...

@l  Perform MLVA typing...
@ + ﬁ ® @Q EJ o T 3 ZRITEXperiment typ

-

g

Figure 1.5: Menu and buttons generated by the MLVA plugin in the Main window.

Before the database can actually be used to determine VNTR copy numbers, an MLVA schema
should be set up first (see 2).

All rights reserved. Not for Diagnostic Use.



Chapter 2

Setting up an MLVA schema

2.1 MLVA principles

A VNTR (Variable Number of Tandem Repeats) locus typically exhibits a large range of copy
numbers, even among highly related bacterial strains. For a selected set of tandem repeats,
comparison of the copy numbers between bacterial strains can be used to obtain insight about
the relationships at a micro-evolutionary level.

In VNTR copy number analysis, a VNTR locus is PCR-amplified using conserved primers, located
outside the tandem repeat. The size in base pairs (bp) of each PCR product therefore corresponds
to the sum of the size of the tandem repeat plus the offsets at both ends (see Figure 2.1).

/

AmpliconSize = OffsetSize + (CopyNumber x RepeatSize)

with OffsetSize = F-Offset + R-Offset

Figure 2.1: Calculation of repeat copy numbers from fragment sizes.

Knowing the repeat size, the copy number can theoretically be calculated as follows:

AmpliconSize — Of fsetSize
RepeatSize

CopyNumber =

Sizing of the obtained PCR products is typically done via capillary electrophoresis. In practice,
observed metrics for a VNTR locus may differ from the theoretically calculated metrics. Defining a
VNTR mapping is a method to deal with these size deviations. A mapping essentially consists of
a series of VNTR bins, namely one bin for each possible VNTR copy number. A bin corresponds
to a size range (defined by a minimum and maximum size), that the VNTR copy number is known
to exhibit based on previous experience.

Obviously, sizing differences are expected to be larger between capillary electrophoresis equip-
ment from different vendors or from separate product lines than between two apparatuses from
the same type. Laboratories that own more than one type of automated sequencer can define
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a machine type for each type of sequencer, not only to accommodate for the observed sizing
differences but possibly also for different dye sets used.

In a typical MLVA (Multi-Locus VNTR Analysis) experimental setup, a number of VNTR loci
(i.e. target VNTR regions on the genome) are selected that are sufficiently and complementary
discriminatory for the organisms studied.

With MLVA typing, we mean the process of assigning types (typically numbers) to VNTR copy
number profiles. Similar to MLST typing, this greatly improves the communication in scientific
reports. An MLVA typing schema therefore consists of a list of types, with for each type the
corresponding VNTR copy numbers for all VNTRs examined in the typing schema and optionally
the clonal complex that the type belongs too.

An MLVA schema contains all the above information, i.e. theoretical VNTR definitions, mappings,
machine types (if defined) and MLVA typing schemas. The MLVA plugin allows you to create more
than one MLVA schema, which is very useful e.g. in case the database contains strains belonging
to more than one species.

2.2 The MLVA management window

In the Main window, select MLVA > MLVA management window... (). Initially, when there is
no MLVA schema present yet, the Import schemas dialog box will pop up (see Figure 2.2).

Import schemas ? *

(@) Provide an MLVA schema name

() Import schema(s)

Figure 2.2: The Import schemas dialog box.

There are two options for adding a new MLVA schema:

e Provide a MLVA schema name: This option allows you to create a new MLVA schema
from scratch. Enter a Name for the MLVA schema and define the schema in the MLVA
management window.

e Import schema(s). Import one or more schemas that were defined in another BIONUMER-
ICS database, either by yourself or by somebody else. Check this option and browse for
the XML file containing the MLVA schema. This file can be located on your local hard drive,
on a network drive or on the internet. In the latter case, an URL should be provided. See
2.7 for more information about exporting an MLVA schema to an XML file. Check Create
fingerprint types to let the software create the fingerprint type experiments that are asso-
ciated with the VNTRs as defined in the schema. This is the recommended option when
importing an existing MLVA schema in an empty database. If you already imported one or
more capillary electrophoresis runs, uncheck Create fingerprint types and link the VNTRs
manually to the corresponding fingerprint type.

When the <OK > button is pressed, the character types [SCHEMA _NAME]_vals and [SCHEMA _NAME] frags

All rights reserved. Not for Diagnostic Use.



2.3. VNTR definitions 11

are created automatically. They will be used, respectively, to store the VNTR copy numbers and
the molecular sizes (in bp) for each VNTR defined in the schema.

Next, the MLVA management window will open. Figure 2.3 shows the MLVA management window
when only a MLVA schema name was provided.

MLVA management — [m| X
File Edit View Window Help

B + x <Al VNTRS> + B x + B x

Name w  Start v

=1 MySchema
Theoretical

Histogram
L 4>

Q This schems has no WVNTRs! Please add 8 VNTR. A

Figure 2.3: The MLVA management window with an empty MLVA schema
“MySchema” created, ready to start defining VNTRs.

The MLVA management window consists of four dockable panels:

e The Schemas panel displays a tree-like overview with all MLVA schemas defined in this
database and their corresponding mappings, typing schemas and instrument types (if de-
fined). Each schema has at least one mapping ("Theoretical’) that corresponds to the theo-
retical prediction of the VNTR bins based on the VNTR definitions (see 2.3).

e In the VNTRs panel, all defined VNTRs for the highlighted schema in the Schemas panel
are shown in a grid with their Name, Offset, Repeat size, Minimum count, Maximum count,
Tolerance and the associated Fingerprint type.

e The Bins panel shows the VNTR bins for the highlighted VNTR in the VNTRs panel in a grid
with their Start and Stop metrics and the Value (i.e. the copy number).

e Electropherograms for the selected database entries and the corresponding VNTR are plot-
ted Histogram panel, against a backdrop of the VNTR bins for the highlighted VNTR.

2.3 VNTR definitions

The copy number of a VNTR can be theoretically calculated from its metrics values when its offset
and repeat size are known (see 2.1).

To add a VNTR to a schema, select Edit > VNTRs > Add VNTR... ( +). This action calls the
Add VNTR dialog box (see Figure 2.4).

All rights reserved. Not for Diagnostic Use.



12 2. Setting up an MLVA schema

Add VNTR ? *

Name: I:I

Offset [ ]

Repeat size: I:I

Copy range: l:l_ I:I

Tolerance: I:I

Fingerprint type: | <None= w
cancel

Figure 2.4: The Add VNTR dialog box, prompting for all parameters needed to
define a VNTR.

This dialog box prompts for following parameters:

e Name: This name should be unique and will be used for further reference. For each VNTR,
a character with the same name will be automatically created in the [SCHEMA_NAME] vals
and [SCHEMA NAME] frags character types.

e Offset: Each fragment consists of a repeat portion and a constant portion due to the fact
that the primers do not occur exactly at the start and the end of the repeat region. This
parameter specifies the size (in base pairs) of the constant portion.

e Repeat size: This parameter specifies the size of a unit repeat block (in base pairs).

e Copy range: Specifies the minimum and maximum number of copies that the plugin will
consider during the copy number determination. Within the same lane and the same dye,
more than one VNTR can be loaded if there is a sufficient difference in fragment size. Im-
posing a limit on the copy range allows the software to distinguish which band corresponds
to which VNTR.

e Tolerance: This parameter specifies the maximum difference in base pairs between the
expected fragment length and the actual length.

e Fingerprint type: This drop-down list contains all fingerprint types defined in the database
and is used to indicate in which fingerprint type this VNTR was run. The fingerprint type is
determined by the dye and — if several pools are used — by the pool tag (see 3).

Pressing <OK> will add the VNTR to the schema. The VNTR will be listed in the VNTRs panel of
the MLVA management window and the bins that were calculated based on the theoretical values
provided are shown in the Bins panel.

A VNTR can be edited at any time by highlighting it in the VNTRs panel and selecting Edit >
VNTRs > Edit VNTR... (%). This action opens the Edit VNTR dialog box for that VNTR.

This dialog offers the same set of parameters as the Add VNTR dialog box does. However, once
a VNTR is defined, its Name cannot be edited anymore.

As an alternative to using the Edit VNTR dialog box, the VNTRs can be edited directly in the VN-
TRs panel by clicking twice on a cell in this grid panel. Please note that the associated fingerprint
type cannot be edited this way.

A VNTR can be removed from a schema by highlighting it and selecting Edit > VNTRs >
Remove VNTR ( x ). The software will ask for confirmation before actually deleting the VNTR.

All rights reserved. Not for Diagnostic Use.
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2.4 Mapping definitions

2.41 Creating a mapping

In practice, often small deviations from the theoretical metrics are observed. To accommodate for
this, the user can define one or more custom mappings in an MLVA schema. Such a mapping is
essentially a set of VNTR bin definitions, i.e. for each possible VNTR copy number a minimum and
a maximum size in base pairs.

To create a new mapping for the highlighted schema in the Schemas panel, select Edit > Map-
pings > Add mapping... ( + ). The Add mapping dialog box pops up (see Figure 2.5).

Add mapping ? X

@ Copy bins from existing mapping
(O Import bins from text file

O Create mapping without bins

Source mapping: Theoretical ~

Figure 2.5: The Add mapping dialog box.

A unique Mapping name should be provided for the new mapping.

Three options are available to create a new mapping:

e Copy bins from existing mapping: With this option selected, a Source mapping can be
selected from a drop-down list, from which the VNTR bins are copied. This copy can then
be the starting point for a new mapping by editing the VNTR bins (see 2.4.2).

e Import bins from text file: This option allows you to browse for a Mapping file, from where
the bin information is imported. See 2.4.3 for more information on how to create a Mapping
file.

e Create mapping without bins: This option simply creates a new mapping, without any
VNTR bin definitions. Since the bins should be defined manually one by one (see 2.4.2), this
is generally not the recommended option.

Pressing <OK> will add the new mapping to the MLVA schema. It will be shown in the tree
overview in the Schemas panel of the MLVA management window. When Copy bins from exist-
ing mapping or Import bins from text file was selected, the bins from the existing mapping or
the file, respectively, will be shown in the Bins panel for the highlighted VNTR in the VNTRs panel.

2.4.2 Editing a mapping

A mapping is edited by adding, deleting or editing the VNTR bin definitions. A bin is added to the
highlighted mapping in the Schemas panel by selecting Edit > Bins > Add bin... ( +). The Add
bin dialog box pops up (see Figure 2.6).

All rights reserved. Not for Diagnostic Use.



14 2. Setting up an MLVA schema

y Theoretical mappings cannot be edited and a warning message will be displayed when
trying to add, delete or edit a VNTR bin definition. The bins in a theoretical mapping
are solely determined by the VNTR definitions (Offset, Repeat size, Tolerance, etc.; see

2.3).

Add bin ? X

Start:

]
]

Value:

Figure 2.6: The Add bin dialog box to add a VNTR bin to a mapping.

Start and Stop are respectively the minimum and the maximum metrics value (in base pairs) for
the fragment to be assigned to this VNTR bin. Values containing decimal digits (e.g. “174.27”) are
allowed.

Value corresponds to the name of this bin. Typically, this will be an integer (i.e. the VNTR copy
number), but other values are allowed as well (e.g. “4s”).

When the <OK> is pressed, BIONUMERICS will check the entered values (Start and Stop
should be decimal numbers, with Stop larger than Start, the bin should not overlap with any
existing bin and the entered Value should not correspond to an existing bin) and add the bin to
the mapping if OK.

For each bin created, a corresponding character mapping with the same name as the bin’s Value
will be created in the [SCHEMA_NAME]_vals character type.

A bin can be deleted from a mapping with Edit > Bins > Remove bin ( x ). The software will
ask for confirmation before actually deleting the VNTR bin.

There are basically two ways to edit an existing bin:
1. By editing the Start, Stop and Value for the bin, much in the same way as when creating a
new bin.
2. Graphically, by drag-and-drop of the bins in the Histogram panel.

For the first method, highlight the bin in the Bins panel and select Edit > Bins > Edit bin... ().
This action displays the Edit bin dialog box for the highlighted bin (see Figure 2.7).

Edit bin ? X

Start:

Stop: 282.0

NOTE: The bins can be also be edited
in the Histogram panel by holding the
Shift or Ctrl key while dragging the
selected bin.

Figure 2.7: The Edit bin dialog box to edit a VNTR bin.

This dialog box allows to edit the Start, Stop and Value for the bin in the same way as described
for the Add bin dialog box (see higher).

All rights reserved. Not for Diagnostic Use.



2.5. Instrument types 15

As an alternative to using this dialog box, the values can be edited via drag-and-drop in the Bins
panel.

For editing VNTR bins in a graphical fashion, fingerprint curves should be displayed in the His-
togram panel (see Figure 2.8). Hence, electropherograms should be imported first (see 3) and
fingerprint types should be assigned to the VNTRs in the VNTR definitions (see 2.3).

MLVA management - O X
File Edit View Window Help
B + X <Al VNTRs> + E} x + E? X
Name w  Start -
=l MySchema VNTROD1 130 3 0 50 1.0 MLVAMPIE-FAM A 81.0 870 0 ~
Theoretical VNTROOZ B4 0 50 2.0 MLYAMPIVIC 94.0 100.0 1
Custom VNTROD3 84 13 0 50 3.0 MLVAMPINED 107.0 113.0 2
VNTROD4 145 7 0 50 2.0 MLVAMPIPET 120.0 1260 3
VNTRO0S 93 21 0 50 9.0 MLVAMPZE-FAN 133.0 138.0 4
VNTRO0G 143 0 50 2.0 MLVAMPZVIC 146.0 1520 5
VNTROO7 50 [ 0 50 2.0 MLVAMPZPET 159.0 185.0 6
4 172.0 1780 7
i 4 185.0 191.0 8 &
U ¢k
Q  Mumber of curves platted: 30 (20 entries seleced) ~
320000
240000
16000.0
80000
0.0 i J.\\ “ l
& 110 180 210 260 310 80 410 480 10 Q 10 v
< >

Figure 2.8: The MLVA management window with fingerprint curves and VNTR bins
displayed in the Histogram panel.

In the Histogram panel, click on the bin which needs to be edited. The bin will now be highlighted
in orange. To set the Start value of a bin, Ctrl+click on the left side of the bin and drag it to the
desired position. Similarly, to set the Stop value of a bin, Ctrl+click on the right side of the bin
and drag it to the desired position. To reposition a bin without changing its width, use Shift+click.

2.4.3 Exporting a mapping

An existing mapping can be exported with Edit > Mappings > Export mapping.... The resulting
export.csv file will open in your system’s default CSV editor (often MS Excel). This file can be
used in the Add mapping dialog box to import a new mapping from (see 2.4.1).

2.5 Instrument types

Only in cases where the same MLVA experiments are run on different types of capillary elec-
trophoresis equipment (possibly also using a different dye set), it will be necessary to define more
than one instrument type.

Select Edit > Instrument types > Add instrument type... to open the Add instrument type
dialog box (see Figure 2.9).

Enter the Instrument type name and press <OK>.
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Add instrument type ? *
Instrument type name: l:l

Figure 2.9: The Add instrument type dialog box.

As soon as an instrument type is added, the Instrument type name will be displayed between
brackets next to each mapping as a reminder that these are specific for a certain type of automated
sequencer (see Figure 2.10).

- MySchema

Theoretical (Applied BioSystems)
Custom (Applied BioSystems)
Theoretical (Beckman)

Figure 2.10: Detail of the Schemas panel, showing an MLVA schema with two in-
strument types.

When a second, third, etc. instrument type is added, only the theoretical VNTR definitions are
taken over, since custom mappings are apparatus-specific and will need to be redefined anyways.
Furthermore, since most likely the fingerprint data from the new instrument type will be stored in
a different set of fingerprint types, the VNTRs are not linked yet to any fingerprint type.

To rename an existing instrument type, select Edit > Instrument types > Rename instrument
type.... The Rename instrument type dialog box pops up (see Figure 2.11).

Rename instrument type ? *
Rename the instrument type Beckman - | into AB SCIE)d

Figure 2.11: The Rename instrument type dialog box.

The instrument type to be renamed can be selected from the drop-down list and the new name
should be provided in the text field. Pressing <OK> will rename the instrument type.

An instrument type can be deleted by highlighting one of the mappings that belong to the instru-
ment type in the Schemas panel and selecting Edit > Instrument types > Remove instrument
type. The software will ask for confirmation before removing the instrument type.

2.6 MLVA typing

To create a new MLVA typing schema, select Edit > Typing schemas > Add typing schema....
This action opens the Add typing schema dialog box (see Figure 2.12).

This dialog box prompts for a Name for the MLVA typing schema. In the VNTRs list below, all
VNTRs from the MLVA schema are listed. Using Ctrl+click and Shift+click, those VNTRs on
which the typing should be performed, can be highlighted in the list.

All rights reserved. Not for Diagnostic Use.
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Add typing schema ? *

VNTRs: | VNTROO1
WNTROO0Z
WNTROO3
WNTROO4
WNTROOS
WNTROOE
WNTROOT

Figure 2.12: The Add typing schema dialog box.

Pressing <OK> will create an MLVA typing schema with the provided name. It will be available
from the drop-down list in the header of the VNTRs panel.

At this stage, the MLVA typing schema is created but it consists only of a subset of the VNTRs
from the MLVA schema, i.e. no actual typing information is available yet.

To edit the MLVA typing schema and specify the additional information, select File > Typing...
(@7). This opens the Select typing dialog box (see Figure 2.13).

Select typing ? *

U515 Wy Ty ping (No typing)

Figure 2.13: The Select typing dialog box.

Highlight the MLVA typing schema that you want to edit in the list and press <Edit>. This action
will display the Typing settings dialog box (see Figure 2.14).

For MLVA typing schemas that lack typing information, the text 'No typing’ is mentioned
between brackets next to the typing schema name. This is the case for the MyTyping
in Figure 2.13.

In the upper part of the dialog box, the Database information for the MLVA typing should be
specified:

e From the drop-down list next to Type information field, the entry information field to store
the MLVA type in needs to be provided. The <Create new> option allows you to create a
new entry information field, for which you can specify a name in the Create new information
field dialog box when the < OK> button is pressed.

e Specifying an entry information field to hold the clonal complex information (CC information
field) is optional; select <None> if no clonal complex information is available.

e The Qualifier for unknown types is the text that will be displayed in the Type information
field when the MLVA profile does not correspond to a known type in the database. The
default value is “Unknown”.

Two options are available for providing the typing data, i.e. the information about which combination

All rights reserved. Not for Diagnostic Use.
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Typing settings ? *

Database information

Type information field: <Create news> w

CC information field: <None= e

Qualifier for unknown types:

Typing source
(® Enter types manually

C) Import types from external source

Select file or enter url:

Figure 2.14: The Typing settings dialog box.

of VNTR copy numbers (for VNTRs included in the typing schema) corresponds to which MLVA
type (under Typing source):

e Enter types manually: Choose this option to enter the type and VNTR profile for each type
individually in the Typing management window.

e The option Import types from external source allows you to import a CSV or tab-delimited
text file containing the typing data, either from a local or network drive or from a URL.

The required format for Import types from external source is a comma or tab-

f separated file with a header consisting of "Type”, a list of all VNTRs included in the
typing schema and "Clonal complex”. Each row represents an MLVA type, with the cor-
responding VNTR copy numbers and optionally the clonal complex. Such a file can be
exported from the Typing management window by clicking the column properties button
+ and selecting Save content to file.

If the <OK > button is pressed with Import types from external source selected, the types from
the external file will be imported and displayed in the Typing management window (see Figure
2.15). Alternatively, if Enter types manually was selected, the software will ask "Do you want to
scan the selected entries for types?”. If VNTR copy numbers were determined already (see 4),
the software will scan the selected entries for new VNTR types and propose to add these to the
database (see further for the description of the Update dialog box). Next, the Typing management
window will open (see Figure 2.15).

The Typing management window provides an overview of the types that are currently present
in the MLVA typing schema, with the clonal complex they belong to and the corresponding copy
numbers for each of the VNTRs that are included in the typing schema.

The settings for this MLVA typing schema can be accessed via File > Settings.... This action
displays the Typing settings dialog box, as discussed earlier.

A new MLVA type can be manually added with Types > Add type... ( +). This opens the Add
new type dialog box (see Figure 2.16).

In this dialog, you can enter the Type, Clonal complex and copy numbers of each of the VNTRs
(under Profile). Pressing <OK> will add the MLVA type to the list in the Typing management
window.

All rights reserved. Not for Diagnostic Use.
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MLVA typing management (MySchema : MyTyping) - O *
File Types Window Help
+ B x vl
Type h
1 5 2 3 1 2 2 2 ~
2 5 2 3 1 3 2 2
3 [ 2 3 1 2 2 2
4 5 2 3 1 5 2 2
4 2 3 1 3 2 2
[ 4 2 3 1 2 2 2
T 3 2 3 2 3 3 2
8 3 2 3 1 2 2 2
w
£ >

Figure 2.15: The Typing management window.

Add new type ? *
Definitions.

Tope: ]
Profile

WNTR Value

WNTROO1

WNTROOZ2

WNTROO3

WNTROO04

WNTROOS

WNTROO0E

WNTROOT

Figure 2.16: The Add new type dialog box, to manually add a type to the MLVA
typing schema.

A highlighted type in the Typing management window can be edited with Types > Edit type...
(%) This action will open the Edit type dialog box (see Figure 2.17).

This dialog allows you to edit the Type, Clonal complex and copy numbers of each of the VNTRs
(under Profile).

A type can be deleted by highlighting it in the Typing management window and selecting Types >
Remove type ( x ). The software will ask for confirmation before actually removing the type from
the database.

The types in the Typing management window can be sorted on any column by first highlighting
the column and then selecting Types > Sort types (I\).

The action that is triggered by Types > Update types ( © ) depends on whether the VNTR profiles
are stored locally (option Enter types manually in the Typing settings dialog box) or when they are
taken from an external source (option Import types from external source in the Typing settings
dialog box):

e With locally stored VNTR profiles, selecting Types > Update types ( v ) will check for new
types on the currently selected entries. When no entry selection is present, the software will

offer to scan the complete database. In case entries are found with MLVA types that are not
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Edit type ? X
Definitions.

Profile

WNTR Value
WNTROO1 5
WNTROOZ2 2
WNTROO3 3
WNTROO04 2
WVNTROOS 2
WVNTROO0E 2
VNTROOT 2

Figure 2.17: The Edit type dialog box.

yet defined in the MLVA typing schema, the new types will be reported in the Update dialog
box (see Figure 2.18).

e When VNTR profiles are stored in an external file, selecting Types > Update types (v )
will update the BIONUMERICS database with the profiles from the external source.

Found 2 new types in 20 entries.

Hits Type WNTR... WNTR.. WNTR.. WNTR.. WNTR.. WNTR.. WNT|
1 7 3 2 3 2 3 3 2
1 8 3 2 3 1 2 2 2
£ >
Would you like to add these to the database?
oK Cancel

Figure 2.18: The Update dialog box.

This dialog box will report any new types that were found among the selected entries. Pressing
<OK > will add these types to the MLVA typing schema. Pressing <Cancel> will keep the MLVA
typing schema in its current state.

A complete MLVA typing schema can be removed by selecting it from the drop-down list in the
toolbar of the VNTRs panel and using Edit > Typing schemas > Remove typing schema.
The software will ask for confirmation before actually deleting the MLVA typing schema.
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2.7 Exporting and importing an MLVA schema

A complete MLVA schema, including VNTR definitions, mappings, instrument types and MLVA
typing schemas can be exported with File > Export to XML.... This action opens the Export
schema dialog box (see Figure 2.19).

Export schema ? X

File: | Browse...

Figure 2.19: The Export schema dialog box.

This dialog allows you to enter (or browse for) a file name under which to save the XML file
containing the MLVA schema definitions.

An XML file containing an MLVA schema, created as described above, can be imported in another
database via File > Import from XML.... The Import schemas dialog box pops up (see Figure
2.20).

Import schemas ? *

File or url: | | Browse...

Create fingerprint types

Figure 2.20: The /mport schemas dialog box.

In the File or URL text field, enter or browse for the XML file containing the MLVA schema defini-
tions. If the file is located on a web server, enter the URL that points to this file.

Check Create fingerprint types to let the software create the fingerprint type experiments that
are associated with the VNTRs as defined in the schema. This is the recommended option when
importing an existing MLVA schema in an empty database. If you already imported one or more
capillary electrophoresis runs, uncheck Create fingerprint types and link the VNTRs manually to
the corresponding fingerprint type.

Press <OK> to import the MLVA schema definitions from the XML file. If an MLVA schema with
the same name already exists in the database, the software will ask whether or not to overwrite
the schema.
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Chapter 3

Importing and processing capillary
electrophoresis data

3.1 Pooling strategies

VNTR amplification products are usually analyzed on automated sequencers using capillary elec-
trophoresis. These instruments allow different VNTRs to be pooled using different color dyes and
run together on the same capillary column. A pool (sometimes called panel) is a mixture of usu-
ally 4 or 5 dyes, one being a reference sample for fragment size calculation, the others containing
each a VNTR for a given strain or sample. The pooling can happen through multiplex PCR or the
amplification products can be mixed after PCR. The number of PCR amplicons that can be pooled
together depends on (1) the number of color dyes used: if 5 color dyes are used, 4 differently
labeled fragments can be pooled (one dye contains the reference sample), and (2) the possibility
to combine PCR-amplicons with significantly different lengths.

Figure 3.1 shows a typical setup where 4 PCR products (target VNTRs) are mixed in one pool,
using 5 color dyes. Since in this example in total 8 VNTR targets are examined per sample, two
pools are generated, each containing 4 target PCR products.

For economy reasons, several VNTRs are sometimes marked with the same dye and loaded as
a mixture in the same column of a capillary sequencer. A condition is that the mixed VNTR PCR
products have size ranges that do not overlap. Using the above example, an alternative set-up is
given in Figure 3.2, where PCR has been carefully designed so that each time a short and a long
amplicon can be labeled with the same dye and mixed in the same pool.

Thus, each VNTR in the MLVA experimental setup is defined by a pool, a dye and a size range.
The size range is defined by the repeat length, the offset and the copy number range (see 2.1).
Note that the size range is only important in case different VNTRs are marked with the same dye.

3.2 Data formats

When fingerprints are run on a capillary sequencer, the resulting data can have two fundamentally
different formats:

e Curve files (also referred to as electropherograms, chromatogram files or trace files): The
binary encoded raw data as produced by the capillary electrophoresis equipment. Since it is
the raw data, it contains the complete information but some fingerprint preprocessing (e.g.
normalization, band assignment, ...) in BIONUMERICS is required.
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24
Genome of SampleX ~
PCRI PCR2 PCR3 PCR4 PCR5 PCR6  PCR7 PCR8
Targets
'\
Pools

A /\ /L Trace files
)’ 7 >

File: SampleX_Pool2.fsa

File: SampleX_Pooll.fsa

Figure 3.1: Schematic overview of the relation between VNTR loci (= PCR targets),
pools and curve files in a typical MLVA experimental setup. In this example, only one

target gene is used per dye in the same pool.

Genome of SampleX ~
PCR1 PCR2 PCR3 PCR4 PCR5 PCR6  PCR7 PCR8
Targets
'\
Dyel Dyel
Pools
Pool 1 -
/\ Trace files

File: SampleX_Pooll.fsa

Figure 3.2: Schematic overview of the relation between VNTR loci (= PCR targets),
pools and curve files in an alternative MLVA experimental setup. In this example,
two compatible targets (i.e. with different lengths) are labeled with the same dye and

mixed in one pool.

e Peak tables: Text files containing a listing of peaks from the chromatograms, with their
corresponding metrics (sizes in base pairs) and peak height and/or peak area. This type

All rights reserved. Not for Diagnostic Use.



3.3. Importing and processing sequencer data: examples 25

of data has been processed by the software which controls the capillary electrophoresis
equipment.

y In contrast to the .fsa files generated by Applied Biosystems sequencers, the .scf
raw curve files generated by Beckman-Coulter equipment are not corrected for spectral
overlap of the fluorescent dyes. This is generally not a problem when a single data
channel is used. However, in experimental setups where all four dyes are employed
(i.e. three data channels and one reference channel), it is advised to import .crv files
in BIONUMERICS. The latter files can be exported from the Beckman-Coulter software

and contain curves which are corrected for cross talk.

Both formats can be imported into BIONUMERICS using the import routines available in the Import
dialog box. The Import dialog box is called with the command File > Import... (G, Ctri+l).
e Curve files (i.e. electropherograms) can be imported in the database with the option Import
curves listed under Fingerprint type data in the import tree.
e Peak files can be imported in the database with the option Import peak table listed under

Fingerprint type data in the import tree.

The following chapter illustrates the import and processing procedures using example data sets
for curve files (3.3.1) and peak tables (3.3.2).

3.3 Importing and processing sequencer data: examples

3.3.1 Importing and processing curve files

3.3.1.1 Sample data

Raw curve files from Applied Biosystems and Beckman (now AB SCIEX) sequencers can be im-
ported directly in BIONUMERICS. A batch of Applied Biosystems curve files can be downloaded
from the Applied Maths website (https://www.applied-maths.com/download/sample-data, click
on "VNTR sequencer trace files”). These example files will be used to illustrate the import steps.
Eight VNTR targets per sample were amplified: two pools were generated (MP1 and MP2), each
containing four PCR products, using four color dyes (6-FAM, VIC, NED, and PET).

3.3.1.2 Importing curves

3.1 Select File > Import... (&, Ctrl+l) to call the Import dialog box, choose Import curves under
Fingerprint type data and press <Import>.

3.2 Browse to the downloaded and unzipped example data folder VNTR sequencer trace files
and select all Applied Biosystems curves files (extension .fsa). Press <Open>.

The files are displayed in the Input wizard page and the default suggested Fingerprint file name
is the folder name.

3.3 Change the name to Batch1 and press <Next> (see Figure 3.3).
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Import fingerprint curves ? *

Input
Select the data to import.

Select curve file(s): [ cosersi10..AN2006-0003_MP1-140708.fsa A Browse...
| | C\Users\10..\N2008-0003_MP2-140708.fsa Delete
| | C\Users\10..\N2008-0004_MP1-140708.fsa

Delete Al

| | C\Users\10..\N2008-0004_MP2-140708.fsa
| | C\Users\10..\N2008-0021_MP1-140708.fsa
| | C\Users\10..\N2006-0021_MP2-140708.fsa
| | C\Users\10..\N2008-0022_MP1-140708.fsa
| | C\Users\10..\N2008-0022_MP2-140708.fsa
| | C\Users\10..\N2008-0040_MP1-140708.fsa

| C\Users\10...\N2006-0040_MP2-140708 fsa ¥
40 file(s), 3 Mb

Fingerprint file name: | Batch1 |

m

Figure 3.3: Selected curve files and fingerprint file name.

The way the information should be imported in the database should be specified with an import
template. In the example data set, the dye name can be parsed from the file information and the
sample and pool information can be parsed from the file names.

3.4 Select the predefined template Example import with pools and press the <Preview> button
to check the rules applied on the selected files.

Preview ? hed
Nr.  Fingerprint pool Fingerprint dye Key 2
1 MP1-140708 G-FAM N2006-0003
2 MP1-140708 Vic N2006-0003
3 MP1-140708 NED N2006-0003
4 MP1-140708 PET N2006-0003
5 MP1-140708 LIZ N2006-0003
[ MP2-140708 G-FAM N2006-0003
7 MP2-140708 viC N2006-0003
8 MP2-140708 NED: N2006-0003
9 MP2-140708 PET N2006-0003
10 MP2-140708 LIZ N2006-0003
" MP1-140708 G-FAM N2006-0004
12 MP1-140708 ViC N2006-0004
13 MP1-140708 NED: N2006-0004
14 MP1-140708 PET N2006-0004
15 MP1-140708 LIZ N2006-0004
16 MP2-140703 G-FAM N2006-0004
17 MP2-140708 viC N2006-0004
18 MP2-140703 NED: N2006-0004
19 MP2-140708 PET N2006-0004 N

Figure 3.4: Preview of predefined template.

In the preview we see that the part of the file name appearing before the underscore is linked to
the Key field. The curve dyes are also correctly linked to the Fingerprint dye type. In a next step,
we will modify the rule for the Fingerprint pool: we will link the part of the file name appearing
after the underscore and before the hyphen (”-") to the Pool field.

3.5 Close the preview.

3.6 Make sure the predefined template Example import with pools is still selected and press the
< Edit> button to edit the rules.
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3.7 Check the option Show advanced options, make sure the second row is selected in the grid
panel and press the <Edit parsing> button.

3.8 In the Data parsing dialog box, update the data parsing string: “*_[DATA]-*". The asterisk will
serve as wildcard.

3.9 Press the <Preview> button and press <OK> when the parsing is correct (see Figure 3.5).

Edit data parsing ? *

@ Parse component: find the component [DATAT, use ™ as wildcard

O Regular expression: match the expression and use the subexpression

Data parsing string: * [DATA}* ~ |
Data decoration: | [DATA] v|
Preview

Data: [ N2006-0003_MP1-140708 || Preview...
Output: | 1P |

Figure 3.5: Parsing string.

The Import rules dialog box is updated.

3.10 Press the <Preview> button to check the outcome of all defined import rules (see Figure 3.6).

Preview ? X
Nr.  Fingerprint pool Fingerprint dye Key =
1 MP1 G-FAM N2008-0003
2 MP1 Vic N2008-0003
3 MP1 NED: N2008-0003
4 MP1 PET N2008-0003
5 MP1 LIZ N2008-0003
[ MP2 G-FAM N2008-0003
7 MP2 viC N2008-0003
8 MP2 NED: N2008-0003
9 MP2 PET N2008-0003
10 MP2 LIZ N2008-0003
" MP1 G-FAM N2008-0004
12 MP1 Vic N2008-0004
13 WP NED NZ008-0004
14 MP1 PET N2008-0004
15 MP1 LIZ N2008-0004
16  MP2 G-FAM N2008-0004
17 MP2 viC N2008-0004
18  MP2 NED: N2008-0004
19 MP2 PET N2005-0004 2

Figure 3.6: Preview of the import rules.

3.11 Close the preview and press <Next> to go to the next step.
In the example data set, the LIZ channel contains the size standard (GeneScan 500 LIZ).
3.12 Make sure LIZ is selected as Reference dye and press <Next> and <Finish>.
The predefine import template is now updated.

3.13 Make sure <Create new> is selected as fingerprint type experiment, make sure the Example
import with pools template is selected and press <Next>.
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3.14 Specify a name for the new base fingerprint type experiment (e.g. MLVA) and press <OK> and
confirm.

3.15 Confirm the proposed OD range.

Create new ? *

Provide a name for the new fingerprint type:

|
Cancel

Figure 3.7: New base fingerprint type experiment.

A fingerprint type needs to be present in the database for each pool and dye combination. The
names of these fingerprint types are composed of the base fingerprint type name, followed by the
pool name, and the name of the dye. If one or more of these fingerprint types are not present in
the database, a new dialog box pops up, listing the missing fingerprint types (see Figure 3.8).

MNew experiment types ? *
These 10 new experiment types will be created:

MLVAMP16-FAM ~

MLVAMPILEZ

MLVAKMPINED

MLVAMP1PET

MLVAMPIVIC

MLVAMP2E-FAM A

Do you want to continue?

Yes 3 No

Figure 3.8: Missing fingerprint experiments.

3.16 Confirm the creation of the missing fingerprint type experiments.
3.17 Press <Next> to confirm the creation of new entries in the database.

3.18 Make sure Open curve preprocessing window is checked in the last step and press
<Finish>.

For each dye checked in the Dyes panel of the Import data dialog box, a new fingerprint file is
created, composed of the file name specified and the name of the dye (e.g. Batch1_LIZ). These
files are displayed in the Fingerprint files panel. The reference file is shown in the Link column.
Double-clicking on a fingerprint file opens the Fingerprint window. If lane information was imported
with the individual lanes, this information is displayed in the Fingerprint information panel.

The imported fingerprint lanes are linked to new entries in the database. The lanes are linked
to the corresponding fingerprint "dye” type. The names of these fingerprint types are composed
of the base fingerprint type name, followed by the pool name, and the name of the dye. The
fingerprint type experiments are displayed in the Experiment types panel.

Entries for which fingerprint data was imported are selected in the database.

After data import, the Main window looks as in Figure 3.9.

3.3.1.3 Processing curves

When the option Open curve preprocessing window was checked in the last step of the import
routine, the Fingerprint curve processing window opens when pressing the <Finish> button. All
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Figure 3.9: The Main window after import of the data.

channels from the run are automatically loaded and displayed in the Fingerprint curve processing
window.

The Fingerprint curve processing window can also be called from the Main window
by highlighting one of the channels in the Fingerprint files panel and selecting Open
fingerprint data... (5). Alternatively, you can first open the Fingerprint window with
Edit > Open highlighted object... (I, Enter) and then select File > Edit fingerprint
data... (E).

3.19 Click on the @ icon left of the data channels in the Channels panel.
The data channels are now hidden from the view and its icons are displayed as
3.20 Use the zoom sliders on the left and on top to optimize the display of the fingerprint curves.

Since the raw chromatogram files have not undergone any preprocessing, normalization will have
to be performed. This requires a reference system to be defined, based upon the marker peaks
available in the reference dye.

3.21 Make sure the reference dye is the only dye visible in the upper panel.

3.22 Select Bands > Search reference bands... (di, Ctrl+F) to call the Search reference bands
dialog box.

3.23 Leave the default settings unaltered and press <OK>.

The bands that fall within the specified criteria are marked with a solid line at the band’s position
(see Figure 3.10).

3.24 To have a reference system automatically created based on a lane containing commercial size
marker, first highlight a suitable lane and then select References > Define size standard....

This will display the Size standard dialog box, from which a size marker can be selected (see
Figure 3.11).

In the example curve files, the GeneScan 500 LIZ size standard is used as reference, containing
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Figure 3.10: The Fingerprint curve processing window only displaying the reference

dye.

Size standard

Pre-defined standard:

Standard fragment list:

GeneScan™ 120 LIZ®

GeneScan™ 500 LIEZ&
GeneScan™ 600 LEZ®
GeneScan™ 1200 LEZ&
GeneScan™ 350 ROX™
GeneScan™ 400HD ROX™
GeneScan™ 500 ROX™
GeneScan™ S00XL ROX™
GeneScan™ 350 TAMRA™
GeneScan™ 500 TAMRA™
GeneScan™ S00XL TAMRA™
GeneScan™ 720 LEZ®

35,50,75,100,139,150,150,200,250,300,340,350,400,450,49
0,500

|:| Invert ordering
Map to selected lane
() Right to left

(O Left to right

Cancel

Figure 3.11: Select marker from the list.

16 bands with known molecular weight.

3.25 Select GeneScan 500 LIZ from the list, select Pattern match and press <OK> twice.

3.26 Save the data to the database with File > Save ([E), Ctrl+S). Confirm the action.

BIONUMERICS will automatically create the reference system and calibration curve for each of
the fingerprint types. Since this allows the calculation of metrics information, a metrics scale now
becomes available in the upper part of the Fingerprints panel.

Normalization is achieved by assigning bands in the reference channel to external reference posi-
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tions.

3.27 To normalize a complete run at once, select Normalization > Auto assign reference posi-
tions (all lanes)... (&%, Ctrl+A), leave all settings unaltered and press <OK>.

3.28 When the assignment of the marker bands to reference positions is made, the data can be
shown in normalized mode with Normalization > Show normalized view (=&, Shift+N).
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Figure 3.12: Normalized view - reference dye.

3.29 Click on the  icon left of the data channels in the Channels panel.

3.30 Click on the @ icon left of the LIZ reference channel.
The data channels are now shown and the reference channel is hidden from the view.

3.31 Select Bands > Search data bands... (*, Ctrl+Shift+F) to call the Search data bands dialog
box.

3.32 Check Remove doublets, Remove shadow bands, Filter by fragment length and specify a
minimum length of 50. Press <OK>.

3.33 Save the changes and close the Fingerprint curve processing window. Confirm the new de-
faults.

The reference system and calibration curve are automatically created for each of the fingerprint
types. We can check this from the Main window:

3.34 Double-click on the base fingerprint type in the Experiments panel to open the Fingerprint type
window.

3.35 In the Fingerprint type window, call Settings > Edit reference system, or double-click in the
RO1 panel to call the Fingerprint Reference system window.

A calibration curve for the reference system R0O1 of the base fingerprint type is displayed.

3.36 Close the Fingerprint Reference system window and the Fingerprint type window.
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Figure 3.13: Normalized view - data dyes.
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3.3.2 Importing peak data from peak table files

Text files containing a
can be downloaded fro
sample-data, click on

listing of peaks can be imported in BIONUMERICS. An example peak file
m the Applied Maths website (https://www.applied-maths.com/download/
"WVNTR sample peak table”). This example file will be used to illustrate the
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import steps in this tutorial.

3.37 Select File > Import... (&7, Ctrl+l) to call the Import dialog box, choose Import peak table
under Fingerprint type data and press <Import>.

3.38 Browse to the downloaded and unzipped example data folder VNTR Peak table and select the
Beckman Sample.txt sample file. Press <Open>.

The path is displayed in the Input wizard page.

3.39 Check Import as fingerprint file, specify a name (e.g. Beckman1) and press <Next>.

Import fingerprint peak table ? *

Input
Select the data to import.

Select file: | ..\Downloads\Beckman_Sample.ted | Browse...

Import as fingerprint file

Fingerprint file name: Beckman1 |

Figure 3.15: Selected peak table file.

The way the information should be imported in the database can be specified with an import
template. In the example Beckman peak file, the dye, sample and pool information is provided.

3.40 Select the predefined template Beckman with pools and press < Edit> to call the Import rules
dialog box.

The Import rules dialog box lists the import rules defined for the import template Beckman with
pools.

3.41 Press the <Preview> button to check the parsing of the file information based on the rules
defined for the template.

From the preview (Figure 3.16), it can be seen that all information from the example file is parsed
correctly.

3.42 Close the preview and press <Next> twice and <Finish>.

3.43 Make sure Create new is selected as base fingerprint type experiment, select the Beckman
with pools template and press <Next>.

3.44 Specify a name for the new base fingerprint type experiment (e.g. MLVA) and press <OK>.
Confirm the creation of the new experiment in the database.

Since a new fingerprint type experiment is created and added to the database, the Experiment
settings wizard page pops up prompting for some settings.

3.45 For this exercise, enter an Intensity range of “65536” (= 16-bit), a Min. fragment length of
“10”, and a Max. fragment length of “700” (see Figure 3.18). Press <OK>.
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Preview ? *
Nr.  Fingerprint pool  Fingerprint dye Size Height Area leMarker Key ~
1 M1 D1 7331 2702 G444 No Sample001
2 M1 D1 15276 2697 6004 No Sample001
3 M1 D1 169.47 2553 5890 No Sample001
4 MM1 D1 183.77 532 1344 No Sample001
5 M1 D1 199.59 4007 3477 No Sample001
6 M1 D1 24015 TN 1639 No Sample001
7 M1 D1 26424 T35 1674 No Sample001
8 MM1 D2 209.23 52168 134445 No Sample001
9 M1 D3 149.76 30888 45112 No Sample001
10 MM1 D4 179.14 40489 88822 No Sample001
1 MM2 D1 137.09 853 2034 No Sample001
12 MM2 D1 199.21 618 1507 No Sample001
13 MM2 D1 23899 833 1808 No Sample001
14 MM2 D1 259.04 3849 1885 No Sample001
15 MM2 D3 401.08 52128 114847 No Sample001
16 MM2 04 147.22 51152 110424 No Sample001
17 MM3 D1 137.13 554 1241 No Sample001
18 MM3 D1 199.23 475 1099 No Sample001 W
£ >

Close

Figure 3.16: Preview.

Create new ? *

Provide a name for the new fingerprint type:

Cancel

o
s

Figure 3.17: New base fingerprint type experiment.

Experiment settings ? *

Please provide the following experiment settings:

Min. fragment length:
Max. fragment length: 700
Dizplay resolution:
Intensity range: 65-5-36{

Cancel

Figure 3.18: Experiment settings.

A fingerprint type needs to be present in the database for each pool and dye combination. The
names of these fingerprint types are composed of the base fingerprint type name, followed by the
pool name, and the name of the dye. A new dialog box pops up, listing all missing fingerprint types
(see Figure 3.19).

3.46 Confirm the creation of the missing fingerprint type experiments.

3.47 Press < Finish> to confirm the creation of new entries in the database.

For each import dye, a new fingerprint file is created, composed of the file name specified and the
name of the dye (e.g. Beckman1_D1). These files are displayed in the Fingerprint files panel.

BIONUMERICS reads the band positions from the mapped "SIZE” column, the peak heights from
the mapped "HEIGHT” column, the area information from the mapped "AREA” column and gen-
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MNew experiment types ? *

Thesze 23 new experiment types will be created:

MLVAMKADA -
MLVAMMADZ
MLVAMMADS
MLVAMMADS
MLVAMM2D1
MLVAMMZD3 v

Do you want to continue?

Yes ] No

Figure 3.19: Missing fingerprint types.

erates densitometric curves using this information. The imported fingerprint lanes are linked to
new entries in the database. The lanes are linked to the corresponding fingerprint "dye” type. The
names of these fingerprint types are composed of the base fingerprint type name, followed by
the pool name, and the name of the dye. The fingerprint type experiments are displayed in the
Experiment types panel.

If no reference system has been specified for the base fingerprint type, BIONUMERICS creates
for all missing fingerprint types and the base fingerprint type, a linear reference system between
the user-defined Minimum and Maximum fragment length positions, and copies the reference
system to a calibration system.

Entries for which fingerprint data was imported are selected in the database.

After data import, the Main window looks as in Figure 3.20.

Import peak table file - BioNumerics — o %
File Edit Database Analysis Scripts Window Help

B=H & O h
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Figure 3.20: The Main window after import of the data.

All rights reserved. Not for Diagnostic Use.



36

3. Importing and processing capillary electrophoresis data

All rights reserved. Not for Diagnostic Use.



Chapter 4

Calculating and assigning VNTR copy
numbers

4.1 Automatic assignment

VNTR copy numbers can be determined for selected entries in the database.

1.1 Select the entries in the database for which you want to calculate the copy numbers.

1.2 Select MLVA > Assign VNTRs... (&1).

The Assign VNTRSs dialog box pops up, listing all VNTRs defined in the database (see Figure 4.1).

Assign VNTRs ? *

Schema

KySchema w

Mapping

Custom -

|:| Set unazsigned to negative value

Figure 4.1: The Assign VNTRs dialog box, to determine VNTR copy numbers for
the selected entries in the database.

This dialog box allows you to select an MLVA Schema, since more than one MLVA schema may
be defined in the database. It also allows you to select a Mapping from any of the mappings
(theoretical or custom mappings) defined in the selected MLVA schema.

Enable the option Set unassigned to negative value to score the absence of a VNTR as neg-
ative, rather than absent. All absent VNTRs will then be scored with the character value ”-2” in
the character type [SCHEMA _NAME] vals. The absent VNTRs, all having the score "-2”, will be
considered as a separate category for each VNTR when clustering the character information in
the [SCHEMA _NAME] vals experiment using the categorical coefficient.

Press <OK> to look for VNTRs in the fingerprints of the selected entries.

When the assignment is complete, the VNTR reporting window will pop up (see 4.2).
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4.2 Assignment report

After assignment of the VNTRs in the database, the VNTR reporting window is displayed (see
Figure 4.2). This window basically contains a table, listing all selected entries (keys) as rows and
all VNTRs from the MLVA schema as columns. Note that this interactive report window can be
called at any time from the Main window with MLVA > Assignment report ... ([).
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File Report Window Help
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Figure 4.2: The VNTR reporting window.

Each cell, corresponding to an entry/VNTR combination, provides information about the copy
number assignment.

e Any number displayed in a cell corresponds to the copy number determined for the corre-
sponding entry/VNTR combination. When only a number is shown, this means that only a
single band falls within the expected size ranges (bins) for the selected VNTR mapping and
hence that the assignment is unambiguous.

e A number followed by a question mark between brackets (e.g. "5 (?)”) means that more than
one band in the fingerprint falls within the expected size ranges for the VNTR. The VNTR
assignment algorithm selects by default the copy number that corresponds to the band with
the largest peak height.

e In case a copy number was manually assigned (see 4.3), the copy number will be followed
by ”"(manual)” to indicate this fact. Please note that double assignments can be only be made
manually (e.g. "3/5 (manual)”).

e A hyphen (”-”) means that no feasible band was found, i.e. none of the bands present in the
fingerprint fall within the expected size ranges for the VNTR.

e The text "No data” will be displayed when no fingerprint experiment exists for this entry/VNTR
combination.
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e The text "N/A” will be displayed when a VNTR assignment has not been performed yet for
this entry/VNTR combination.

Alternative to copy numbers, the peak heights can be displayed with Report > View peak heights.
This command is a toggle, so select it again to return to the view with copy numbers.

Additional information is visualized via color scales:

e The default view (which can be called any time with Report > Show errors (.i.)) highlights
possible errors: orange when no feasible band is detected and yellow when more than one
feasible band is found.

e With Report > Show absolute deviation (), the cell colors provide an indication of the
absolute deviation of the observed fragment size from the expected fragment size. The cell
color ranges between green-yellow-orange-red according to increasing absolute deviation.
This makes it easy to detect the magnitude of differences between the observed and ex-
pected sizes at a glance.

o With Report > Show deviation (4.), the cell colors express the deviation of the observed
size from the expected size. The cell color ranges from blue (when the observed size is
smaller than the expected size) over white to red (observed size is larger than the expected
size).

2.1 Double-click on a key/VNTR cell to open the Experiment card window.

Any cell in the VNTR reporting window for which there is VNTR assignment present, can be
double-clicked to open the fingerprint profile in the Fingerprint curve processing window (see 4.3).

4.3 Checking and manually assighing VNTR copy numbers

When the MLVA plugin is installed in the database, the Fingerprint curve processing window will
contain an additional VNTR assignments panel (see Figure 4.3). This panel contains a grid with
VNTR copy number assignments, identical to the VNTR reporting window and with the same
display options (MLVA > Show errors ( i ), MLVA > Show absolute deviation (") and MLVA
> Show deviation (.{); see 4.2 for an explanation). In addition, VNTR bins and labels with the
assigned copy numbers are drawn on the Fingerprints panel, together with the electropherograms.

To switch to normalized view, select Normalization > Show normalized view (=, Shift+N).

The automatic VNTR copy number assignment can be ran again with MLVA > Automatic as-
signment..., e.g. to undo any manual assignments to use another mapping. This action opens
the Assign VNTRSs dialog box (see Figure 4.4).

This dialog box allows you to select a Mapping from any of the mappings (theoretical or custom
mappings) defined in the MLVA schema.

Enable the option Set unassigned to negative value to score the absence of a VNTR as neg-
ative, rather than absent. All absent VNTRs will then be scored with the character value ”-2” in
the character type [SCHEMA _NAME]_vals. The absent VNTRs, all having the score ”-2”, will be
considered as a separate category for each VNTR when clustering the character information in
the [SCHEMA _NAME] vals experiment using the categorical coefficient.

Press <OK> to start the automatic VNTR copy number assignment.
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Fingerprint curve processing - O X
File Edit View Bands References Normalization MLVA Window Help
3 = " 1 T + og
B o 2 e I R
VNTR assignments
X -
— ; VLT A
Mormalized view is not active
VNTROO1 -
@ E N2006-0003 5 - 3 1
7 VALY NZ006-0004 - z 207 z(7)
1 N2006-0003 [MLVAMP1E-FAN] ~  12006-0021 5 2 3 1)
N2006-0022 5 z 3 1
N2006-0040 3 H 3 2
@ N2006-0063 5 z 3 1
&, NZ006-0082 5 2 3 1
NZ006-0089 = 2 3 1
NZ006-0112 4 3 2 2
N2006-0123 4 2 3 1
N2006-0152 5 2 3 1
N2006-0170 3 2 3 1
v N2006-0172 5 2 3 1
< > N2006-0179 4 = 2 1
N2006-0185 4 - 2 1
raoeo138 s o2 3
% | T T ‘ N2006-0208 6 2 3 1
N2006-0231 5 - 3 2
57 N2006-0232 5 2 3 1
@I Batch 1_6-FAM 6-FAM A N2008-0233 4 2 3 1
Iﬁ Batch 1_LIZ LEZ
I Bateh 1_VIC vic
I Batch 1_NED NED
I Batch 1_PET FET
v
< > < >

Figure 4.3: The Fingerprint curve processing window for a single electropherogram
with VNTR copy number assignment.

Assign VNTRs ? *

Mapping

Theoretical (Applied Biosystems)
Custom (Applied Biosystems)
Theoretical (SCIEX)

[] set unassigned to negative value

Figure 4.4: The Assign VNTRs dialog box.

To assign a VNTR copy number for a single band, first select the band using Ctrl+click and use
MLVA > Manual assignment selected peak (single) (Ctrl+M). A copy number will be assigned
that corresponds to the nearest VNTR bin.

In some profiles, more than one VNTR peak might occur. The MLVA plugin allows you to make
double assignments by selecting two bands with Ctrl+click and MLVA > Manual assignment
selected peak (double).

A VNTR copy number assignment for a selected band can be undone by MLVA > Delete assign-
ment selected peak (Ctrl+Shift+Del).

Deleting a band with Bands > Delete highlighted bands (Del) does not automatically
A removes the VNTR copy number assignment!

With MLVA > Lane view filter (Y/ ), one can toggle to a view mode where all lanes in the finger-
print file are shown or a view mode in which only the relevant lane for the highlighted entry/VNTR
combination in the VNTR assignments panel.
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Chapter 5

Importing repeat numbers from
external files

5.1 Introduction

When VNTR copy numbers are already stored in external text, Excel, or other ODBC-compatible
file, these copy numbers can be imported in BIONUMERICS and stored in the character type
experiment MIRU-VNTR_vals using import routines available in the Import dialog box.

5.2 Import routines

The Import dialog box is called with the command File > Import... (G, Ctrl+l). The import tree
options are organized in groups based upon the type of data (see Figure 5.1).

o With the Import fields and characters (text file) option, listed under the topic Charac-
ter type data in the Import tree, the copy numbers can be imported from text files in the
database and linked to new or existing database entries.

e With the Import fields and characters (Excel file) option, listed under the topic Character
type data in the Import tree, the copy numbers can be imported from an Excel file in the
database and linked to new or existing database entries.

e With the Import fields and characters (ODBC) option, listed under the topic Character
type data in the Import tree, the copy numbers can be imported from ODBC-compatible
files in the database and linked to new or existing database entries.

The import routines will not be covered in detail in this manual.
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5. Importing repeat numbers from external files

Import

Import data

Select the kind of data to import:

@ Recently used

- Entry information data
= Fingerprint type data
. Character type data

Import fields and characters (Excel file)
Import fields and characters (ODBC)
Import characters (db style)

H| Sequence type data

H- g, Matrix type data

[, Trend data type data

H--d Spectrum type data

H- ¥ Sequence read sets data

t-E Data exchange

[ W B e W B e B

Import character and optionally
database information from text
files and link to new or existing
database entries.

Each file should contain a
welkdefined table where a row
corresponds to an entry and
where columns correspond to
characters (and database
fields).

The header of the table should
contain the character names

(and the database information
field names).

Manage import templates

Figure 5.1: The character import routines in the Import dialog box.
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Chapter 6

MLVA typing

6.1 Setting up an MLVA typing

Before a typing can be performed based on MLVA profiles, obviously an MLVA typing schema
should be set up first. This is discussed in 2.6.

6.2 Assigning types

To assign an MLVA type to a selection of entries, use MLVA > Perform MLVA typing... (¢ll). This
action opens the Perform typing dialog box (see Figure 6.1).

Perform typing ? *

Schema

MySchema v

Typing

Wy Typing

Figure 6.1: The Perform typing dialog box.

This dialog box allows you to select an MLVA Schema, since more than one MLVA schema may be
defined in the database. It also allows you to select one or more MLVA typing schemas (Typing)
from any of the MLVA typing schemas defined in the selected MLVA schema (see 2.6).

Upon pressing <OK> in the Perform typing dialog box, the software will determine the MLVA
types and will add these to the entry information field that was specified for the typing information
(see 2.6).

When no [SCHEMA _NAME] frags character experiment is present, the text "No data” is entered.
The text Incomplete profile” will be filled in when copy numbers are not available for all VNTRs as
defined in the MLVA typing schema. For new profiles, i.e. VNTR copy number combinations that
are not in the database yet, the text "Unknown” will be filled in.

When new VNTR profiles were found, the software will display the Update dialog box (see 2.6). In
case the MLVA types are locally stored in the database (option Enter types manually checked in
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the Typing settings dialog box), this dialog will allow you to add the new profiles to the database.
In case the MLVA types are obtained from an external file or URL (option Import types from
external source checked in the Typing settings dialog box), the software will offer to export the
new types to a text file. If <OK> is clicked, the Select file to export dialog box appears, which
allows you to save the text file containing the new VNTR profiles to your hard drive. This file can
then be sent to the MLVA database curators.

The software will automatically change the entry selection to samples that require further exami-
nation, i.e. entries with an unknown MLVA type. This allows you to use e.g. MLVA > Assignment
report ... (fI0) on the selection, to check the VNTR copy number assignments.
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Chapter 7

MLVA data analysis

Some useful features in the context of MLVA/VNTR data analysis will be highlighted in this chap-
ter. More detailed information about the analysis possibilities in the software can be found in the
BIONUMERICS manual.

7.1 Selections in BIONUMERICS

1.1 Select a single entry in the Database entries panel by holding the Ctrl-key and left-clicking on
the entry. Alternatively, use the space bar to select a highlighted entry or click the ballot box
next to the entry.

Selected entries are marked by a checked ballot box (g) and can be unselected in the same way.
1.2 In order to select a group of entries, hold the Shift-key and click on another entry.
A group of entries can be unselected the same way.

1.3 All entries can be selected at once with Edit > Select all (Ctrl+A).

1.4 Clear all selected entries with Database > Entries > Unselect all entries (all levels) (F4).

7.2 The Comparison window

2.1 Make a selection in the Database entries panel (see 7.1).

2.2 Highlight the Comparisons panel in the Main window and select Edit > Create new object...
(+) to create a new comparison for the selected entries.

A Comparison window is created, with the selected database entries. The Comparison window
is divided in six main panels: the Dendrogram panel, which shows the dendrogram if calculated,
the Experiment data panel, showing the images of the experiments, the Information fields panel,
which shows the database fields in the same layout as in the database, the Similarities panel,
which shows the similarity values, the Experiments panel, which shows the available experiment
types and the Groups panel, showing the groups, if defined.

2.3 You can drag the vertical separator lines between the panels to the left or to the right, in order
to divide the space among the panels optimally.
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2.4 Click on the ~ next to the experiment name [SCHEMA_NAME] _vals in the Experiments panel
and select Characters > Show values (1) to display the repeat numbers in the Experiment
data panel (see Figure 7.1).

2.5 In the Comparison window, groups can be created based on a selection (Groups > Create new

group from selection (1 , Ctrl+G)) or based on the content of an information field: right-click
in the header of a field and select Create groups from database field from the menu.

7.3 Cluster analysis

3.1 In the Experiments panel of the Comparison window, make sure the [SCHEMA_NAME] _vals
experiment is selected.

3.2 Select Clustering > Calculate > Cluster analysis (similarity matrix)....

For VNTR data, the coefficients that make most sense are:

e Categorical: preferred if differences in copy numbers should be treated in a qualitative way.

e Euclidean distance: preferred if differences in copy numbers should be treated in a quanti-
tative way (larger difference means more distant organisms).

3.3 Select the Categorical (values) coefficient from the list and press <Next>.

The categorical coefficient compares the repeat numbers to see if they are the same or different
but does not quantify the difference.

3.4 In the second step, choose a clustering method (e.g. UPGMA) and press < Finish>.

When finished, the dendrogram and the similarity matrix are shown in the Comparison window
(see Figure 7.1 for an example). More information about the Comparison window can be found in
the manual.
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Figure 7.1: The Comparison window with a UPGMA tree displayed.
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A minimum spanning tree in BIONUMERICS is calculated the Advanced cluster analysis window.
This window can be launched from the Comparison window:

3.5 Select Clustering > Calculate > Advanced cluster analysis... or press the £ button and
select Advanced cluster analysis to launch the Create network wizard.

The predefined template MST for categorical data uses the categorical coefficient for the calcu-
lation of the similarity matrix, and will calculate a standard minimum spanning tree with single and
double locus variance priority rules.

3.6 Specify an analysis name (for example VNTR1), make sure [SCHEMA _NAME] vals is selected,
select MST for categorical data, and press <Next>.

The Advanced cluster analysis window pops up (see Figure 7.2 for an example). The Network
panel displays the minimum spanning tree, the upper right panel (Entry list) displays the entries
that are present in the tree. The Cluster analysis method panel displays the settings used, in
this example the priority rules that result in the displayed network. The colors of the comparison
groups (if defined) are automatically shown as node colors.
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Figure 7.2: The Advanced cluster analysis window.

3.7 To change the display settings of the network (node/branch labels, node/branch colors, etc.)
press [l or choose Display > Display settings.

Detailed information about the Advanced cluster analysis window can be found in the manual.
3.8 Select File > Save ([H, Ctrl+S) to save the comparison.

All calculations done on the data is stored along. This includes similarity matrices in all experiment
types where they have been calculated and any dendrogram that has been calculated.

3.9 Enter a name, e.g. “MyComp” and press <OK>.

3.10 Close the comparison with File > Exit. The comparison MyComp is listed in the Comparisons
panel of the Main window.

All rights reserved. Not for Diagnostic Use.



48

7. MLVA data analysis

3.11 To open an existing comparison, highlight the comparison in the Comparisons panel and se-
lect Edit > Open highlighted object... (5, Enter). Alternatively, just double-click on the
comparison name.
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